1996 xcr 600 sp pto carb not firing
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

1996 xcr 600 sp pto carb not firing

This is a discussion on 1996 xcr 600 sp pto carb not firing within the The Performance Tuning Shop forums, part of the Snowmobiles category; Hi, change out all fluids on sled and put new throttle/ choke cables on and sync them. But when started pto carbs is not firing ...

Results 1 to 2 of 2

Thread: 1996 xcr 600 sp pto carb not firing

  1. #1
    Member
    This user has no status.
     

    Member #
    45412
    Join Date
    Apr 2015
    Posts
    36

    1996 xcr 600 sp pto carb not firing

    Hi, change out all fluids on sled and put new throttle/ choke cables on and sync them. But when started pto carbs is not firing write . Took temp reading from pto side 75 , 185, 185 temp. Notice when taking carbs apart the jetting was wrong . Usually the pto side has the lower main . So from pto side it read 378, 378, 350. So I asked alit of questions about this so I put a 360 in the pto carb so now it's reads 360, 378 , 378. 40 pilots on all three. Can't get to fire write , have good spark in all three. Thanks for any Info. and can I run two new double fuel pumps mikuni s


    Sent from my iPhone using Tapatalk

  2. #2
    Junior Member
    This user has no status.
     

    Member #
    47177
    Join Date
    Jan 2016
    Posts
    14
    one quick easy thing to check, is the float levers. its really easy if your not paying attention (guess how i know... lol) to put the float lever in upside down. which will allow a small amount of fuel to flow thru. maybe enough to idle. but will cut out as soon as you come off idle. just had this happen after a couple buddys were gonna "help me put my carbs back together" lol. hope this helps ya bud! good luck!

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 1995 xcr 600 pto bearing failiure
    By icejaw in forum Engine
    Replies: 7
    Last Post: 03-13-2013, 09:08 AM
  2. new pics of xcr 600 pto oil
    By knox189 in forum Polaris
    Replies: 14
    Last Post: 09-10-2010, 06:17 PM
  3. FS: 95 XCR 600 with reverse, bad PTO bearing
    By jimmyv13 in forum Parts and Accessories
    Replies: 0
    Last Post: 03-07-2007, 08:36 AM
  4. 1996 XCR 600 carb specs
    By STEVE650 in forum Engine
    Replies: 2
    Last Post: 12-13-2005, 04:29 AM
  5. 95 XCR 600 PTO
    By Dman in forum Polaris
    Replies: 3
    Last Post: 11-25-2005, 10:04 PM