Snowmobile piston gone wrong
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

Snowmobile piston gone wrong

This is a discussion on Snowmobile piston gone wrong within the Sled Shed forums, part of the Snowmobiles category; Working on a 1991 Polaris Indy 500. Took of the head to clean the carbon off the pistons. Cleaned one and it looks great, but ...

Results 1 to 6 of 6

Thread: Snowmobile piston gone wrong

  1. #1
    Junior Member
    This user has no status.
     

    Member #
    52914
    Join Date
    Nov 2016
    Posts
    1

    Snowmobile piston gone wrong

    Working on a 1991 Polaris Indy 500. Took of the head to clean the carbon off the pistons. Cleaned one and it looks great, but the other I noticed something not good. The side where the exhaust port is worn almost worn to the rings. what went wrong and needs to be fixed

  2. #2
    Banned
    is OptiStart is a full featured
    20 channel remote start,
    security, lighting and 3rd
    party control device designed
    for the powersports
    enthusiast. It can literally
    be used to control and monitor
    everthing on your UTV, ATV or
    Snowmobile.
     

    Member #
    51754
    Join Date
    Aug 2016
    Location
    new york
    Posts
    13
    if you should get 2. My guess is to have both cylinders bored with new rings and pistons.

  3. #3
    Junior Member
    is waiting for the cure to my
    summertime blues...
     

    Member #
    45714
    Join Date
    Aug 2015
    Location
    Mason, WI
    Posts
    18
    Its hard to say what went wrong.

    Which piston is about toast? Clutch or recoil side? Post some pics please.

    Sent from my XT1254 using Tapatalk
    I love the smell of 2 stroke in the morning

  4. #4
    Site Supporter
    This user has no status.
     
    Millennium Tech's Avatar
    Member #
    50289
    Join Date
    Apr 2016
    Posts
    11
    Quote Originally Posted by Alwaysfixing View Post
    Working on a 1991 Polaris Indy 500. Took of the head to clean the carbon off the pistons. Cleaned one and it looks great, but the other I noticed something not good. The side where the exhaust port is worn almost worn to the rings. what went wrong and needs to be fixed
    I would check the cylinder to make sure it is still round and within spec. We see a lot of these that come in that are not round or past the service limit and have piston slap happening in them. You may need to just get it plated or an O.B. with a new set of pistons.
    Millennium Technologies
    Jeff Meyer/ Sales & Service
    920/893/5595 ext.351
    jmeyer@millennium-tech.net




  5. #5
    Junior Member
    This user has no status.
     

    Member #
    53938
    Join Date
    Dec 2016
    Posts
    10
    - i just did top end on a Polaris 2003 700 that blew a ring- bought a used cylinder on ebay as it was ruined by the blown ring. put in two new pistons and rings and all is great. i had the cylinders re-etched, cross thatched as it allows more oil to stay on the wall of cylinder as it breaks in the new rings. stayed stock at 81mm with no boring. I did all for less than 400. new from dealer or boring/honing would be 600-900. have ridden 5 times and 75 miles for break in. very fast now.

  6. #6
    Senior Member
    This user has no status.
     
    CanadianXCR's Avatar
    Member #
    6839
    Join Date
    Dec 2004
    Posts
    3,010
    If you expect help, you should at least post a pic as your description could be a few different possible issues. My interpretation of your description sounds like you've run lean and started to melt the crown off the exhaust side of the piston. Millennium's response is also a possibility.
    '98 XCR 440 "Red Rocket"

    370 Mains W/TempaFlow Airbox Vented Under Shelf 1/8 Turn CCW
    17.5 Pilots W/UFO's & Torque Flows
    P-4 286 Needle Jet W/6DH7 Needles #2 Position W/1 .020 EGT Shim
    S53Red Weights, Polaris Almond/Gold W/911 Response Cover
    TEAM TSS98 66-44-.46, Red/Blue
    22/41 Gearing
    Camoplast Ice Ripper
    Kimpex Arrow Skis W/Woodys Carbides
    Koso EGT/H20/RPM Digital Gauge

    '16 Switchback Pro-S 800 Snow Check

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. What is wrong?
    By Shinns11 in forum General
    Replies: 18
    Last Post: 12-19-2008, 11:24 AM
  2. wrong place at the wrong time
    By XLT580kid in forum General
    Replies: 22
    Last Post: 01-15-2008, 12:57 PM
  3. Is there something wrong with me?
    By Rubi in forum Off Topic
    Replies: 16
    Last Post: 11-21-2007, 05:53 PM
  4. is there something wrong
    By 98srx700 in forum General
    Replies: 6
    Last Post: 10-02-2005, 07:36 PM
  5. What Was So Wrong About....
    By Canadian_snow in forum General
    Replies: 1
    Last Post: 02-14-2004, 01:00 AM