starting problems
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

starting problems

This is a discussion on starting problems within the Polaris forums, part of the Brand Specific Snowmobile Discussion category; I have a 2016 pro s switchback 800 with digital display I was riding this weekend and sometimes I had to pull start it the ...

Results 1 to 1 of 1

Thread: starting problems

  1. #1
    Junior Member
    This user has no status.
     

    Member #
    54890
    Join Date
    Jan 2017
    Posts
    1

    starting problems

    I have a 2016 pro s switchback 800 with digital display I was riding this weekend and sometimes I had to pull start it the key didn't work or did my display turn on in the acc position. The electric start would work on and off through the day.its not the battery because when the key worked it had plenty of cranking power. any info??
    Last edited by sevsdad456; 01-10-2017 at 05:52 PM.

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Starting problems
    By Polaris_96xlt in forum The Performance Tuning Shop
    Replies: 0
    Last Post: 03-21-2015, 11:17 AM
  2. starting problems
    By 440_jag in forum Arctic Cat
    Replies: 8
    Last Post: 12-19-2008, 10:33 AM
  3. starting problems
    By biggy in forum The Performance Tuning Shop
    Replies: 3
    Last Post: 02-10-2005, 02:26 PM
  4. problems starting
    By ilovesnow in forum General
    Replies: 20
    Last Post: 12-13-2004, 11:22 AM
  5. Starting Problems
    By XCR_600_TRIPLE in forum The Performance Tuning Shop
    Replies: 8
    Last Post: 01-24-2002, 09:24 AM