XCR 440 owners.
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

XCR 440 owners.

This is a discussion on XCR 440 owners. within the Polaris forums, part of the Brand Specific Snowmobile Discussion category; [ ] Welcome XCR 440 owners and all sled owners. Questions mainly relating to XCR 440's.[ ] Ask away.....[ ] My Red Rocket break system ...

Page 1 of 695 1 2 3 11 51 101 501 ... LastLast
Results 1 to 10 of 6949
Like Tree367Likes

Thread: XCR 440 owners.

  1. #1
    This user has no status.
     
    pierbridge's Avatar
    Member #
    10166
    Join Date
    Nov 2005
    Posts
    48
    []

    Welcome XCR 440 owners and all sled owners.

    Questions mainly relating to XCR 440's.[]

    Ask away.....[]

    My Red Rocket break system was not working properaly.

    And these guys helped fix it....Thanks

    PierBridge.....

  2. #2
    Senior Member
    is Tryin to figure out this new
    formatt. Been awhile since he
    has signed into SF
     
    X-Treme3x's Avatar
    Member #
    6331
    Join Date
    Nov 2004
    Posts
    1,828
    I will bet you $20 I know the problem. I had a problem just like yours last year. You have to take a flash light and look under the cooling line that does through the break system and just below it you will see the brake switch. Its a peice that screws into the system with wires for the tail lights/brak light leading from it. Watch it closely and also listen. Start to pump the break lever and watch for tiny airbubbles/fluid comming from it. Watch the connection prongs where they come out of the switch and you should see the fluid come from there. Tell me what you find.

  3. #3
    This user has no status.
     
    pierbridge's Avatar
    Member #
    10166
    Join Date
    Nov 2005
    Posts
    48
    Thanks XCR4403X.

    Heading to garage now while it's still warm here...Snow and cold are coming!!!!!![]

  4. #4
    Senior Member
    is time to make the firewood!!!
     
    xcr440's Avatar
    Member #
    1505
    Join Date
    Feb 2003
    Posts
    15,721
    Same thing on mine. I had no brakes when I got it. $25 switch will fix it.

  5. #5
    Senior Member
    is Tryin to figure out this new
    formatt. Been awhile since he
    has signed into SF
     
    X-Treme3x's Avatar
    Member #
    6331
    Join Date
    Nov 2004
    Posts
    1,828
    Originally posted by pierbridge
    [br]Thanks XCR4403X.
    Heading to garage now while it's still warm here...Snow and cold are coming!!!!!![]
    Well then...lets get that suckers brakes back then. Gonna need'em on that sled

  6. #6
    This user has no status.
     
    pierbridge's Avatar
    Member #
    10166
    Join Date
    Nov 2005
    Posts
    48
    You guys ROCK!!!!!!!!!![][][]

    Just like you said, I almost gave up on it I could not hear the air coming out "rain []" so I topped off the master and pumped her up and it leaked right were you said.

    Thank You!

    Now where do I find one for $25 Polaris dealers want $66....not a big deal I'll pay it to have my breaks back but if there is one cheaper that would be cool.

    And how do I get at it, do I disasemle the break system or remove the oil reservoir not sure which would be easier.

    Thanks again XCR4403X and XCR440.[8D]

  7. #7
    Senior Member
    is time to make the firewood!!!
     
    xcr440's Avatar
    Member #
    1505
    Join Date
    Feb 2003
    Posts
    15,721
    I removed bolts and lifted up caliper. Not easy but can be done with little removal.

    Price went up after I got mine. They doubled in price.

  8. #8
    Senior Member
    is Tryin to figure out this new
    formatt. Been awhile since he
    has signed into SF
     
    X-Treme3x's Avatar
    Member #
    6331
    Join Date
    Nov 2004
    Posts
    1,828
    I got mine of a 96/97 XCR 600 I think..it came off an older sled. Check around if you know people with some poo parts from 98-96..maybe even the 99 uses the same part? Yeah I did what xcr440 said but I removed on side of the coolant line when I did mine. But yup just unbolt the caliper lift it up and take a wrench and unscrew it. If you have teflon tape it might not even be a bad idea to put a piece around it..but remember to put with the thred and not against.

    Not sure if you know how to bleed it but you will see a nipple I belive just to the right of the calipar, looks almost golden color. First fill you brake fluid back up and put the cap back on. Unscrew the nipple about 1-2 turns and pump the brake handle, you will see fluid comming out. Keep pumping it untill you loose half or 3/4 of the fluid in the resovior then tighten it back up, refill the resovior. You will have to repeat this over a couple times, think I had to do it 3-4x so you can get the air out. Once you have done that fill it up again and pump and slowly tighten it again and pump it untill it gets hard. This make take some time but it should start to stiffen up. I think thats the procedure anyways to what I did. Hope it all works out.

    BTW, you owe me $20 []

  9. #9
    Senior Member
    is time to make the firewood!!!
     
    xcr440's Avatar
    Member #
    1505
    Join Date
    Feb 2003
    Posts
    15,721
    Almost all of the 90's style sleds use the same switch. Have you tried ebay.

    The new switch comes from the factory with red thread sealer already on it.

  10. #10
    Senior Member
    This user has no status.
     
    CanadianXCR's Avatar
    Member #
    6839
    Join Date
    Dec 2004
    Posts
    3,010
    haha..what a coincidence, i was just wroking on my brakes tonite as well..no leaks on my end, but i should take a peek at my switch just in case...My problem was that my brake light was staying stuck on, even though the brakes were disengaged...i ended up taking the caliper and pads off and cleaning and lubing the slides for the pads/caliper. I also cleaned and lubed the caliper piston as well. I then spent over an hour flushing and bleeding the brake system, i accidentally got a bit of air in the bugger so it took me forever, thought i would never get that damn air out...Finally got it worked out, started the sled and the light was staying stuck again...Cracked the bleeder to let a bit of fluid out and played with it some more and so for it hasn't come back on, so i am crossing my fingers it is fixed...didn't feel like driving around with the brake light stuck on and confusing the hell out of other riders...BTW its a Magura brake system...

Page 1 of 695 1 2 3 11 51 101 501 ... LastLast

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

1997 polaris xc440 buying used forum
,
1998 polaris 440xcr brake light on all time
,
1998 polaris xcr 440 for sale
,
1998 polaris xcr 440 pistons
,
how many polaris xcr 440 sp were made
,
ideal rpm for 440 polaris xcr
,
polaris clutch weight chart
,
polaris xcr
,
s44-44-99a1
,
wms bushing
,

www xxcr com 201

,
xcr 440 owners
Click on a term to search for related topics.