Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

High End Bog?

This is a discussion on High End Bog? within the Polaris forums, part of the Brand Specific Snowmobile Discussion category; I have an 03 Edge 700. I have recently put on a mbrp race can and v-force 3 reeds. When the sled gets into the ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: High End Bog?

  1. #1
    This user has no status.
     
    kipper's Avatar
    Member #
    6798
    Join Date
    Dec 2004
    Posts
    321
    I have an 03 Edge 700. I have recently put on a mbrp race can and v-force 3 reeds. When the sled gets into the high rmp's (6500+) the sled just bogs and stays there, also it doesnt idle hardly at all. It will drop to about 200-400 and then just die out. I cant remember what it use to rev to but I believe it was about 7500 or 7700. What could the problem be? Dirty carbs, Bad gas, Need to rejet? Thanks

  2. #2
    This user has no status.
     
    ProRacer's Avatar
    Member #
    13292
    Join Date
    Jun 2006
    Posts
    284
    needs to be jetted most likly and tuned

  3. #3
    Polaris Tech
    is Waiting for the snow to fly...
     
    PolarisEdge's Avatar
    Member #
    10198
    Join Date
    Nov 2005
    Posts
    1,208
    Originally posted by ProRacer
    [br]needs to be jetted most likly and tuned
    Sounds like a jetting issue for sure.... I wouldn't try to run it like that or you will most likley burn it down.

  4. #4
    This user has no status.
     
    kipper's Avatar
    Member #
    6798
    Join Date
    Dec 2004
    Posts
    321
    ok what should the plugs look like?

  5. #5
    Mod-Warrior - Moderator
    is im a nerdy geek attention
    whore wooohooo!!!
     
    Bobinwi's Avatar
    Member #
    296
    Join Date
    Jan 2002
    Posts
    4,321
    plugs should be cardboard brown in color with correct jetting

  6. #6
    is took the sled out today...pure
    bliss
     
    Blackcat's Avatar
    Member #
    6014
    Join Date
    Oct 2004
    Posts
    3,888
    ^ after you run it WOT for 1/2-1 mile or wrapped up pretty good for 30-45 seconds on a stand.

    If you let it idle and then pull them, they will be wet and black every time.

  7. #7
    Senior Member
    is Tryin to figure out this new
    formatt. Been awhile since he
    has signed into SF
     
    X-Treme3x's Avatar
    Member #
    6331
    Join Date
    Nov 2004
    Posts
    1,818
    I cannot see any jetting cause it not to pull top rpm. Perhaps once you do what others recomend check your VES and make sure they are clean and the hole in the cylinder is not plugged either.

  8. #8
    This user has no status.
     
    kipper's Avatar
    Member #
    6798
    Join Date
    Dec 2004
    Posts
    321
    Well I checked the plugs after taking it for a short ride around the yard, and they were the golden brown that you were talking about. So I will check the VES and see if that is the problem. Also I bought all the things off a guy with and RMK 600 and he never had jetted at all, so that leads me to think its something else.

  9. #9
    Senior Member
    is spent 80%of my money on women
    and booze...the rest I wasted.
     
    Luke's Avatar
    Member #
    10429
    Join Date
    Nov 2005
    Posts
    1,438
    Are you sure the 600 can is the right one for your 700. That can really f'things up if it dosnt flow enough for your bigger engine.
    However, aside from the can, It really sould like a jetting or fuel delivery issue. Or possibly the ves.

    Good Luck

  10. #10
    This user has no status.
     

    Member #
    12924
    Join Date
    Mar 2006
    Posts
    123
    i had the same problem with my buddies 700. it turned out that thecarbs were bad. it was just a little bog at first and by the end r the month it was dumb. we ut a new set of carbs on it and it whent like hell again and we tried his carbs an another 700 and it bogged

Page 1 of 2 1 2 LastLast

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •