Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

Any news on polaris reflashing ecu's on 09 sleds??

This is a discussion on Any news on polaris reflashing ecu's on 09 sleds?? within the Polaris forums, part of the Brand Specific Snowmobile Discussion category; I bought new.... a 09 D8 and 136" shift and having fuel mapping issues on both. The d8 has been flashed already but still having ...

Results 1 to 3 of 3

Thread: Any news on polaris reflashing ecu's on 09 sleds??

  1. #1
    This user has no status.
     
    brian1983's Avatar
    Member #
    13086
    Join Date
    Apr 2006
    Posts
    109
    I bought new.... a 09 D8 and 136" shift and having fuel mapping issues on both. The d8 has been flashed already but still having intermittent issues and the 136 shift won't go over 75 mph!!! Wtf!!!! Unacceptable!!! I was told that Polaris is gonna be working with mercury engines to straighten there issues out.Both sleds have been flashed and the shift has a secondary clutch recall done and a reflash before i picked it up!!! Not sure this is for all clean fire engines or just D8's. When are they gonna get their act together!! [!]

  2. #2
    This user has no status.
     

    Member #
    26233
    Join Date
    Mar 2009
    Posts
    3
    Quote Originally Posted by brian1983
    I bought new.... a 09 D8 and 136" shift and having fuel mapping issues on both. The d8 has been flashed already but still having intermittent issues and the 136 shift won't go over 75 mph!!! Wtf!!!! Unacceptable!!! I was told that Polaris is gonna be working with mercury engines to straighten there issues out.Both sleds have been flashed and the shift has a secondary clutch recall done and a reflash before i picked it up!!! Not sure this is for all clean fire engines or just D8's. When are they gonna get their act together!! [!]


    I have a 09 800iq. It ran ok after the first re-map. These motors have been a disaster for Polaris and there is a recall coming. Probably going to change all the pistons in the 800's. They do acknowledge that there is a problem and sounds like they are going to fix it. If you go on hard core sledder and log into the Polaris site go to the post called service guy. He shows a copy of the Polaris letter.

  3. #3
    This user has no status.
     
    brian1983's Avatar
    Member #
    13086
    Join Date
    Apr 2006
    Posts
    109
    how about the 600 2 injector setup in the 136" shift? any word on a re-map on this thing? def a problem!!!

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •