Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

trying to repare Formula ST 1994model range

This is a discussion on trying to repare Formula ST 1994model range within the Ski-Doo forums, part of the Brand Specific Snowmobile Discussion category; Here are some photos: 1. Connection between engine and Sled 2. Connecting wire for the Temperature sensor Can you find TEMPERATURE GAUGE? i cant. Only ...

Page 2 of 15 FirstFirst 1 2 3 4 12 ... LastLast
Results 11 to 20 of 148
Like Tree3Likes

Thread: trying to repare Formula ST 1994model range

  1. #11
    Senior Member
    This user has no status.
     

    Member #
    40017
    Join Date
    Jan 2013
    Posts
    108
    Here are some photos:
    1. Connection between engine and Sled





    2. Connecting wire for the Temperature sensor




    Can you find TEMPERATURE GAUGE? i cant. Only Lamp... So- why is such sensor(with 2 wires)?

    3. Should i buy only with this number, or it does not matter?



    And for CDI



    4. What means these number



    I should buy only from rotax 470 or TRA from other models will be OK?

  2. #12
    Senior Member
    This user has no status.
     

    Member #
    40017
    Join Date
    Jan 2013
    Posts
    108
    Can you make a screen(photo) of Wiring diagram for me? in Clymer Wiring diagram for 1994 consists Temperature Gauge instead of control lamp.I think its a mistake. Also it have Fuel level Gauge (i do not have such gauge and fuel sensor)

  3. #13
    Senior Member
    This user has no status.
     

    Member #
    40017
    Join Date
    Jan 2013
    Posts
    108
    I'd like to look at 1990-1994 Specification booklet p/n 480 1296 00
    Do you know where?

  4. #14
    Senior Member
    This user has no status.
     

    Member #
    40017
    Join Date
    Jan 2013
    Posts
    108
    i studied wiring diagrams and understood that:

    The differences in temperature sending unit (sensor) is in Y/B wire.
    A: In my case this wire (connected to many ather wires in a point) gives input (plus) to the sensor and then through sensor becomes G wire and goes directly to Lamp (my case) or to Temperature Gauge.
    B: In case with older Sensor there is no Y/B wire near the sensor, but it still align to other same wires just under control panel and gives signal to lamp directly. Only green wire goes directly from sensor to Lamp.

    If i'm not wrong- in case of my wiring diagram and old Sensor with hex- i should connect only green wire to sensor.

    Am i right?

  5. #15
    Senior Member
    This user has no status.
     

    Member #
    40017
    Join Date
    Jan 2013
    Posts
    108
    in my case Violet (V) instead of Green (G). V comes through older models...

  6. #16
    Senior Member
    This user has no status.
     

    Member #
    40017
    Join Date
    Jan 2013
    Posts
    108
    I think i must disassemble Drive Pulley, but i scare... i have only drive puller. i think there is rust inside and i need to grease it.

  7. #17
    Senior Member
    This user has no status.
     

    Member #
    40017
    Join Date
    Jan 2013
    Posts
    108
    What can you say about Taiwan pistons? i'll make some photos later. The top ring is a little strange. With the small stair.

  8. #18
    Senior Member
    is Plowing snow
     
    TeamNFG's Avatar
    Member #
    12443
    Join Date
    Feb 2006
    Location
    Gitten'sno Alberta
    Posts
    2,221
    Quote Originally Posted by nprDimas
    I'd like to look at 1990-1994 Specification booklet p/n 480 1296 00
    Do you know where?
    I would think any of that would be in a Ski Doo service manual

    Quote Originally Posted by nprDimas
    i studied wiring diagrams and understood that:

    The differences in temperature sending unit (sensor) is in Y/B wire.
    A: In my case this wire (connected to many ather wires in a point) gives input (plus) to the sensor and then through sensor becomes G wire and goes directly to Lamp (my case) or to Temperature Gauge.
    B: In case with older Sensor there is no Y/B wire near the sensor, but it still align to other same wires just under control panel and gives signal to lamp directly. Only green wire goes directly from sensor to Lamp.

    If i'm not wrong- in case of my wiring diagram and old Sensor with hex- i should connect only green wire to sensor.

    Am i right?
    It sounds like you are on the right path, I can't say yes or no, I don't have a wiring diagram for your sled

    Quote Originally Posted by nprDimas
    I think i must disassemble Drive Pulley, but i scare... i have only drive puller. i think there is rust inside and i need to grease it.
    Both primary and secondary clutchs must be taken apart and cleaned, set up clutchs to proper specs to your altitude. Never grease the clutchs, as they are a dry running set up.
    A special puller is needed to pull the primary clutch, the best are from ski doo, but you can find others online, or on ebay, you need to find one for a 470 TRA

    Quote Originally Posted by nprDimas
    What can you say about Taiwan pistons? i'll make some photos later. The top ring is a little strange. With the small stair.
    I've used jobber pistons before with good luck, but I have no idea where they were made

    Make sure you know the size of piston you have know, purchase the next size up and have the pistons fit to spec

  9. #19
    Senior Member
    This user has no status.
     

    Member #
    40017
    Join Date
    Jan 2013
    Posts
    108
    Hi! I bought this one: NEW SKI DOO CLUTCH PULLER FORMULA MX DLX SL Z 500 583 GRAND TOURING 480 580 470 #230792307802
    I checked it- its OK.

    Gteasing i mean inside the TRA. There special arms with rollers on them. They move it. I saw them on Youtube. I'd like to disassemble before using because sled was under water. i should clean them, little grease and then assemble. I think now a can do it.

  10. #20
    Senior Member
    is Plowing snow
     
    TeamNFG's Avatar
    Member #
    12443
    Join Date
    Feb 2006
    Location
    Gitten'sno Alberta
    Posts
    2,221
    Quote Originally Posted by nprDimas
    Hi! I bought this one: NEW SKI DOO CLUTCH PULLER FORMULA MX DLX SL Z 500 583 GRAND TOURING 480 580 470 #230792307802
    I checked it- its OK.

    Gteasing i mean inside the TRA. There special arms with rollers on them. They move it. I saw them on Youtube. I'd like to disassemble before using because sled was under water. i should clean them, little grease and then assemble. I think now a can do it.
    No grease inside the clutchs, they are a dry system
    just disassemble and clean, replace any wore out parts, ensure the brass bushing in the spring cup is in good shape as well, if it is wore out it can cause binding.
    The same thing needs to be done to the secondary clutch also. Clean, replace wore out parts ensure you have the proper preload tension set to your sleds specs to your altitude

Page 2 of 15 FirstFirst 1 2 3 4 12 ... LastLast

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •