Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

07 phazer problems. shocks and fuel pump/

This is a discussion on 07 phazer problems. shocks and fuel pump/ within the Yamaha forums, part of the Brand Specific Snowmobile Discussion category; so today i was driving my sled and stopped and noticed my fron shocks are like screwed. they are solid very very stiff/hard wat ever. ...

Results 1 to 7 of 7

Thread: 07 phazer problems. shocks and fuel pump/

  1. #1
    sled junkie
    is got a new bike
     
    580mountaincat's Avatar
    Member #
    25280
    Join Date
    Jan 2009
    Posts
    136
    so today i was driving my sled and stopped and noticed my fron shocks are like screwed. they are solid very very stiff/hard wat ever. and its not ice. then i park my sled for and hour and a half go to start and i notice the fuel pump didnt cycle. it cranks over but doesnt start.? any ideas [V][Disappointed][!][}][:0]

  2. #2
    This user has no status.
     

    Member #
    9869
    Join Date
    Oct 2005
    Posts
    1,182
    water get into your shocks and froze up?

    Fuel pump relay, some 07s had this issue in the apex, dont now if same for phazer. You can heat it up by taking it off and putting into your hands for a few minutes. It should start up. Relay needs updated one, few bucks at yamaha shop (if thats the issue) could be several issues but thats the first place I would start.

  3. #3
    This user has no status.
     
    07Phazer's Avatar
    Member #
    12801
    Join Date
    Mar 2006
    Posts
    390
    The fuel pump relay going out isn't out of the ordinary on the early Phazers. I'm not sure which one it is, but I'm sure your dealer would be able to tell you.

    As far as the front shocks being hard, I'm having a similar problem. I'm not really sure of the problem or the fix, but I had planned on replacing all the shocks this summer anyway.

  4. #4
    This user has no status.
     

    Member #
    9869
    Join Date
    Oct 2005
    Posts
    1,182
    the relay doesnt really go out. It gets moisture in, and freezes up. Sometimes on the 07s people would come out to their sleds after it sat at a bar/restaurant and had this issue. Just take it off and warm it up in your hands. Once it fires your all good. I have heard there was a replacement one for it, like 7 bucks or something cheap. Call your dealer and ask.....

  5. #5
    sled junkie
    is got a new bike
     
    580mountaincat's Avatar
    Member #
    25280
    Join Date
    Jan 2009
    Posts
    136
    okay thanks. where can i find the fuel pump relay. my cousins came out amd i wanna show them my new sled eh?so if i need to get a part i will.

    yeah and when you turn the key on it clicks not cycles

  6. #6
    This user has no status.
     

    Member #
    9869
    Join Date
    Oct 2005
    Posts
    1,182
    I cant say for sure on the Phazer.... ask on www.ty4stroke.com its all yammis, all 4 strokes. Someone will be able to tell you within seconds I bet. They have forum just for the phazers too, so you can hook up with others with same sled, issues, interests etc.

  7. #7
    sled junkie
    is got a new bike
     
    580mountaincat's Avatar
    Member #
    25280
    Join Date
    Jan 2009
    Posts
    136
    yeah im a member there to and posted

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •