Skidoo freezes up after powder run
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

Skidoo freezes up after powder run

This is a discussion on Skidoo freezes up after powder run within the Engine forums, part of the The Performance Tuning Shop category; I have a 2003 Skandic SUV 600 and it seems that every time i ride in deep snow I end up needing to put a ...

Results 1 to 8 of 8

Thread: Skidoo freezes up after powder run

  1. #1
    This user has no status.
     

    Member #
    11652
    Join Date
    Jan 2006
    Posts
    13
    I have a 2003 Skandic SUV 600 and it seems that every time i ride in deep snow I end up needing to put a bottle of antifreeze in the tank. How do I stop this from happening? This is crazy. A Ski-Doo that you can't ride in powder. Seems like one carb freezes up and I'm afraid I am going to blow the motor. Any help out there????

  2. #2
    This user has no status.
     

    Member #
    8180
    Join Date
    May 2005
    Posts
    283
    sound like ur getting snow into the air box and its getting into the carb. whats stops the snow from getiing into the airbox on your sled? my friend had a similar problem on his arcticat mountaincat 600 but he had covers for his air box he just was to dumb to use them.

  3. #3
    Senior Member
    This user has no status.
     
    Xcsp610's Avatar
    Member #
    10538
    Join Date
    Dec 2005
    Posts
    526
    A frozen sled is caused by ice lodged in the carb usually by water in the tank or your sled sucking up snow i have seen people with this problem many times check your rubber mounts the connect you air box to you carb check your air box for a hole, I have even seen a guy who on his Zl cracked the frame this caused the snow to extensively shoot up into the bottom of his air box which on most sleds has pre drilled holes in the bottom to allow excess gas to leak out. Mainly check your air box for any way for loose snow to get in.

  4. #4
    Bring It, Don't Sing It!
    is snow on the ground but not for
    long... Not in mood yet to
    wrench on sleds... :(
     
    myvertxcape's Avatar
    Member #
    8313
    Join Date
    Jul 2005
    Posts
    2,973
    You need some powder prefilters for your intake foam from slp. I was also sucking in some snow in deep powder and found that the foam around the headlight wasn't fully sealing it up and snow was going in through there. Don't know how SD's have their intakes but I just removed some screws from a plate on the inside of the hood that removes and added more foam around the headlight, problem solved.

  5. #5
    This user has no status.
     

    Member #
    11867
    Join Date
    Jan 2006
    Posts
    3
    check and make sure there is no gaps between the air box and the vent inside the windshield.If there is there is any gap there, any snow that gets inside your hood may get into the air box then into the carb.

  6. #6
    This user has no status.
     

    Member #
    11652
    Join Date
    Jan 2006
    Posts
    13
    I bought the prefilter from SLP and did not have a problem after. Thanks.

  7. #7
    Senior Member
    This user has no status.
     
    AKnarrowback's Avatar
    Member #
    14032
    Join Date
    Oct 2006
    Location
    Fairbanks Alaska
    Posts
    1,046
    Get a good quality prefilter for the intake. If you can't find an exact fit look for the material to build one. Next, confirm that the air being pulled into the airbox is cold air from outside of the hood. If you are running in the powder for a short distance and the carbs freeze up it is due to moist air being drawn into the carbs. Any snow getting onto the motor or exhaust melts, turns to steam, gets drawn into the airbox and freezes the second it hits the carbs. You need to draw cold air from outside of the hood into the motor, any air from under the hood is a waste of time.

  8. #8
    Junior Member
    This user has no status.
     

    Member #
    53066
    Join Date
    Nov 2016
    Posts
    1
    "i have a 2000 440 barcat that freezes up when its cold it will run good in miled weather but wont run in cold i cleaned out the tank and carbs few times now make shur there was no water there but it still happens i was wondering what els i can try"

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •