Clutch noise?
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

Clutch noise?

This is a discussion on Clutch noise? within the General forums, part of the Snowmobiles category; Im not sure if this is where to post this but im new to this page.. recently i bought a 2012 mxzx 600etec and within ...

"); }
Results 1 to 7 of 7

Thread: Clutch noise?

  1. #1
    Junior Member
    This user has no status.
     

    Member #
    72444
    Join Date
    Dec 2019
    Posts
    2

    Clutch noise?

    Im not sure if this is where to post this but im new to this page.. recently i bought a 2012 mxzx 600etec and within the first 20 miles of riding i noticed a chirp like noise when the clutch engages, first thought it was the belt but it still does it when the belt is taken off.. any help would be greatly appreciated..
    thanks


    Sent from my iPhone using Tapatalk

  2. #2
    Senior Member
    This user has no status.
     
    SnoKing's Avatar
    Member #
    8217
    Join Date
    May 2005
    Location
    Pence WI
    Posts
    374

  3. #3
    Junior Member
    This user has no status.
     

    Member #
    72444
    Join Date
    Dec 2019
    Posts
    2
    Quote Originally Posted by SnoKing View Post
    Ive tried but cant find anything and it wont let me post for some reason


    Sent from my iPhone using Tapatalk

  4. #4
    Senior Member
    This user has no status.
     
    SnoKing's Avatar
    Member #
    8217
    Join Date
    May 2005
    Location
    Pence WI
    Posts
    374
    You have to sign up and register to be able to post. Then they have to accept you
    Last edited by SnoKing; 12-27-2019 at 09:01 AM. Reason: pellong

  5. #5
    Senior Member
    This user has no status.
     
    SnoKing's Avatar
    Member #
    8217
    Join Date
    May 2005
    Location
    Pence WI
    Posts
    374
    Have you tried any lube on the clutch. How many miles on it? Was the clutch ever serviced?

  6. #6
    Junior Member
    This user has no status.
     

    Member #
    72518
    Join Date
    Dec 2019
    Posts
    5
    Quote Originally Posted by nick0108 View Post
    Quote Originally Posted by SnoKing View Post
    Ive tried but cant find anything and it wont let me post for some reason


    Sent from my iPhone using Tapatalk
    me too i try but i didn't find anything
    Last edited by [email protected]; 01-03-2020 at 03:55 PM.

  7. #7
    Junior Member
    This user has no status.
     

    Member #
    65898
    Join Date
    Mar 2018
    Posts
    11
    Loving this thread, I think this is a very interesting discussion

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •