Pro X 700's Rip!!!! - Page 2
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

Pro X 700's Rip!!!!

This is a discussion on Pro X 700's Rip!!!! within the The Performance Tuning Shop forums, part of the Snowmobiles category; I Have good news, i beat my buddies edge X 800 3 out of 4 times so it must be running ok? He has 192 ...

"); }
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 34

Thread: Pro X 700's Rip!!!!

  1. #11
    This user has no status.
     

    Member #
    2394
    Join Date
    Oct 2003
    Posts
    94
    I Have good news, i beat my buddies edge X 800 3 out of 4 times so it must be running ok? He has 192 studs and i have none.

    Still looking for a little more top end, any ideas?

  2. #12
    This user has no status.
     

    Member #
    1059
    Join Date
    Nov 2002
    Posts
    44
    make sure that your cdi has been remapped by the factory...my brother-in-laws 700 was a stone until the cdi was re burnt. huge fix for it.

    that is where i would start first.

    then a epi clutch kit.

  3. #13
    This user has no status.
     

    Member #
    2187
    Join Date
    Sep 2003
    Posts
    312
    part of the top speed issue is the fact that the sled is a ProX, not an XC SP.

    The ProX is more tailored to the racer type person, who wants to ride trails. Therefore, polaris clutches these sleds to be rockets out of the hole, but have low top speeds.

    I never really thought about this until i read a performance test in the latest American Snowmobiler magazine.

    in 0-60ft times, the proX2 800 blew away the ZR900, RX-1, and the ski-doo by over HALF A SECOND.

    I am going off memory, but i believe the X2 was 1.19s in 60ft, cat was 2nd fastest at 1.8s.

    At 660ft+, all the 800s were basically neck and neck, but the polaris proX2 800 they had would only dyno at 123hp... dunno whats up with that, but who knows, maybe its accurate. Anyways, even in 1300ft, the polaris 800 wouldnt radar over 90mph, which was exactly what i was complaining about (on this forum) after i rode my sled for about 400 miles - no top end.

    I finally realize, my sled wasnt designed to be a lake blaster, it was designed to get from idle to 70mph faster than anything out there.

  4. #14
    This user has no status.
     

    Member #
    2394
    Join Date
    Oct 2003
    Posts
    94
    Thank you for all of the comments...

    I believe your correct, this sled is a rocket out of the hole and handles flawlessly. I can be sleeping on the line and still wax my friends 02 edge X 800 until only once way upstairs, i had a bumpy lane and he had a FLAT lane. There must be a best of both worlds setup for holeshot and Top-end???

    I had my CDI reprogrammed from polaris.


    Has anyone tried the change the stock yellow/green Exhaust valve spings to the purple or pink or any others?

  5. #15
    This user has no status.
     

    Member #
    2117
    Join Date
    Sep 2003
    Posts
    2,495
    I haven't messed w/those springs, yet. If you soften them up, which I would do, I guess it turns your sled into an absolute gas guzzler.

  6. #16
    This user has no status.
     

    Member #
    2394
    Join Date
    Oct 2003
    Posts
    94
    Funny you say that i was told that buy a friend and he said the same thing and he didn't feel or notice any difference...

  7. #17
    This user has no status.
     

    Member #
    2117
    Join Date
    Sep 2003
    Posts
    2,495
    They're only a couple bucks each and real easy to change, so it might not be a bad idea to swap them around for a hundred miles or so. That way you can see for yourself. I've heard people saying things DON'T make a difference when I know first hand they DO make a difference, on my sled anyways. Maybe the springs make more noticeable differences in certain setups than others? I don't know, but it'll probably something I expirement with in the next couple months. Do you know who sells them? I've seen only yellow available from SLP.

  8. #18
    This user has no status.
     

    Member #
    2394
    Join Date
    Oct 2003
    Posts
    94
    Yes, EPI, Hotseat, SLP but i will get them from polaris. I will look at what Polaris is using in some other models and go from there. I have a set of purple and i will try them next time out and let you know.

  9. #19
    This user has no status.
     

    Member #
    3894
    Join Date
    Jan 2004
    Posts
    27
    The 03 pipes are not made properly you have to cut 3/4" out of the headpipe just the other side of the exhast flange and 3/4" just in front of the bracket that sits on the shock tower then trim the heatsheild to fit, then change the clutching to run at proper rpm. I was given this information by a Polaris rep.I tried it on my 03 RMK and it works you get the top end thrust that it seems to be missing.

  10. #20
    Super Moderator
    is Meatball CYI
     
    RMK-KING's Avatar
    Member #
    786
    Join Date
    Oct 2002
    Location
    ND
    Posts
    11,272
    Or just put a after market single pipe on..

Page 2 of 4 FirstFirst 1 2 3 4 LastLast

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

polaris xc sp 2003 600 did those cdi have to be remapped

,

will clutch work make my polaris edge x 800 2002 perform better and be faster then stock

Click on a term to search for related topics.