starting problem please help
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

starting problem please help

This is a discussion on starting problem please help within the The Performance Tuning Shop forums, part of the Snowmobiles category; Ihave a 96 skidoo touring E I purchaced for my son. If I try to start it with the electric start, it it will roll ...

"); }
Results 1 to 5 of 5

Thread: starting problem please help

  1. #1
    This user has no status.
     

    Member #
    2745
    Join Date
    Nov 2003
    Posts
    2
    Ihave a 96 skidoo touring E I purchaced for my son. If I try to start it with the electric start, it it will roll over fine but will not fire. But if I use the pull start it will start with one or two pulls.
    also if I just tap the key a little, sometimes it will go.I have tried different combinations of throttle and prime.

    does anyone have an idea what might cause this?

    thanks, John[maroon][/maroon][maroon][/maroon]

  2. #2
    This user has no status.
     

    Member #
    1761
    Join Date
    Mar 2003
    Posts
    68
    It souns like your ignition is not working right. Because you said when you tap it, it sometimes works, it makes me think it is killing the spark sometimes.

    A good test would be to pull the plugs and watch to see if it is sparking when you use the electric start (with the plugs grounded to the motor)

    If you find it is nt always sparking, then just replace the ignition
    Hope this helps.

  3. #3
    Senior Member
    is looking for a yellow injector
    for a fusion
     
    TriumphoverU's Avatar
    Member #
    12
    Join Date
    Jun 2001
    Posts
    2,729
    As Kawasakikid said pull the plugs and check for spark while using electric spark. If it doesnt work i'd be checking out the ignition switch for problems.

  4. #4
    This user has no status.
     

    Member #
    2745
    Join Date
    Nov 2003
    Posts
    2
    Thanks guys, I will try that and let you know what happens.

  5. #5
    Junior Member
    This user has no status.
     

    Member #
    72880
    Join Date
    Jan 2020
    Posts
    1
    I have the same problem/ same sled,did switch cure issue ?

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •