2006 Arctic Cat, Speedometer problem
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

2006 Arctic Cat, Speedometer problem

This is a discussion on 2006 Arctic Cat, Speedometer problem within the Arctic Cat forums, part of the Brand Specific Snowmobile Discussion category; Hey folks, I was lucky enough to buy a 2006 Cat very cheap. Yes, it had certain electric problems and some stuff I needed to ...

"); }
Results 1 to 5 of 5
Like Tree2Likes
  • 1 Post By whitexc
  • 1 Post By JackWFlarry

Thread: 2006 Arctic Cat, Speedometer problem

  1. #1
    Junior Member
    This user has no status.
     

    Member #
    69806
    Join Date
    Feb 2019
    Posts
    2

    2006 Arctic Cat, Speedometer problem

    Hey folks,
    I was lucky enough to buy a 2006 Cat very cheap. Yes, it had certain electric problems and some stuff I needed to work on. Anyways, I managed to fix a lot of problems, but the speedometer along with 2 screens on the dash still do not work. I have certain knowledge in car electricity, not in snowmobiles (this is the 1st snowmobile I've ever owned, btw), but they are pretty similar. Now, my question is about getting the stock unit replaced with an aftermarket one.
    Any recommendations on what's going to work better on the Cat? I've seen plenty of options, but I'd rather follow your recommendations, than the sales'...
    Thanks!

  2. #2
    Senior Member
    This user has no status.
     

    Member #
    12399
    Join Date
    Feb 2006
    Location
    WNY
    Posts
    2,549
    Welcome. Being not the most familiar with the dash pack you are talking about, my suggestion would be to find a wiring diagram, test for good voltage and make sure grounds are clean/secure. Aside from that, find a wrecked sled or call a bone yard and get a new dash/gauge set-up shipped in. As far as aftermarket, not sure how they hook into the existing harness without some serious wiring alterations. Good luck and keep us posted.
    JackWFlarry likes this.
    Polaris...it IS the way out!

  3. #3
    Junior Member
    This user has no status.
     

    Member #
    69806
    Join Date
    Feb 2019
    Posts
    2
    I appreciate the warm welcome and the reply, sir. I investigated the diagram and grounds are okay.
    I was just reading some old thread on some other forum (don't recollect the name), and people are saying, that it is a common problem about the Cats like mine. It appears that gauges they are not waterproof on that generation, so I feel I will need to pick a used one and get it siliconed (if that will add at least some protection to the unit), or will go an aftermarket route (Koso's stuff, perhaps). I am still not sure how to hook up everything right to make the aftermarket gauge work right though.
    Last edited by JackWFlarry; 02-27-2019 at 08:00 AM.
    whitexc likes this.

  4. #4
    Junior Member
    This user has no status.
     

    Member #
    65898
    Join Date
    Mar 2018
    Posts
    8
    Tagged. This is going to be good
    Last edited by terryna; 02-26-2019 at 09:34 PM.

  5. #5
    Senior Member
    This user has no status.
     

    Member #
    12399
    Join Date
    Feb 2006
    Location
    WNY
    Posts
    2,549
    Quote Originally Posted by terryna View Post
    Tagged. This is going to be good
    Trolling on this fine winter's night?

    Sent from my moto z3 using Tapatalk
    Polaris...it IS the way out!

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. '95 Arctic Cat Puma Speedometer Cable
    By SledderFL in forum Arctic Cat
    Replies: 8
    Last Post: 01-12-2010, 03:32 PM
  2. 2006 Fusion 700 Speedometer Connection
    By Sled-dog in forum Polaris
    Replies: 4
    Last Post: 10-14-2009, 04:22 AM
  3. Replies: 36
    Last Post: 01-19-2009, 07:53 PM
  4. arctic cat speedometer
    By ditchbangncat in forum Arctic Cat
    Replies: 1
    Last Post: 01-26-2007, 07:26 PM
  5. Strange problem w/ speedometer
    By Rhino15_98 in forum The Performance Tuning Shop
    Replies: 3
    Last Post: 12-30-2006, 11:41 PM