Installing engine in 2001 polaris edge 600
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

Installing engine in 2001 polaris edge 600

This is a discussion on Installing engine in 2001 polaris edge 600 within the Polaris forums, part of the Brand Specific Snowmobile Discussion category; When I pulled engine to rebuild it came out hard besause the mount studs bound, now trying to put it back in again the mount ...

"); }
Results 1 to 9 of 9

Thread: Installing engine in 2001 polaris edge 600

  1. #1
    Member
    This user has no status.
     

    Member #
    8660
    Join Date
    Sep 2005
    Posts
    46

    Installing engine in 2001 polaris edge 600

    When I pulled engine to rebuild it came out hard besause the mount studs bound, now trying to put it back in again the mount studs don't allow it to just drop in. The mount are in good shape and there is no aparent issue.

    Does anyone have a trick to getting the engine back in the chassi???

    Thanks in advance for suggestions
    Last edited by river-ratskier; 12-01-2013 at 01:12 PM.

  2. #2
    Senior Member
    is Snows hear and I am not !!
     
    Whitepowder's Avatar
    Member #
    33988
    Join Date
    Jan 2011
    Location
    East bethel
    Posts
    151
    It almost has to drop straight down at a angle, I don't think there's any tricks just have to get the angles right

  3. #3
    Member
    This user has no status.
     

    Member #
    8660
    Join Date
    Sep 2005
    Posts
    46
    Ii got it in but I had to loosen carb side stud mounts, I tried every angle posible first. but ther was no way was it going to go in. I than retightened stud mounts.

    Any thoughts? Thanks for the reply.

  4. #4
    Senior Member
    is is not riding his xc this
    year, sold it and am spending
    more time in the shop fixing
    the gritters....
     
    Like2tinker's Avatar
    Member #
    37304
    Join Date
    Dec 2011
    Location
    Earlville, New York
    Posts
    171
    Get the engine on the rear mounts first then twist motor onto the fronts. Did you remove the torque bumpstop? U will have to an order to slide the engine up far enough on the rear mounts to get the front mount studs back in.

  5. #5
    Senior Member
    is is not riding his xc this
    year, sold it and am spending
    more time in the shop fixing
    the gritters....
     
    Like2tinker's Avatar
    Member #
    37304
    Join Date
    Dec 2011
    Location
    Earlville, New York
    Posts
    171
    Well you got it anyway.always more than one way to "skin a cat" or fix a polaris. Lol

  6. #6
    Member
    This user has no status.
     

    Member #
    8660
    Join Date
    Sep 2005
    Posts
    46
    Thanks for replies. Yes I did loosen torque stop and I tried both back studs first than front studs first. There was no way it was going to drop onto other studs until I removed back stud mounts.

    FYI anyone, hope others have a easier time. It was not like the experiencr I have had with older Indy's.

  7. #7
    Senior Member
    is getting ready for hillclimb
    season..
     
    polaris91's Avatar
    Member #
    12737
    Join Date
    Mar 2006
    Posts
    4,331
    i always just unbolt the gold brackets from the bulkhead and leave them attached to the motor mounts and it drops in and out no problems. fast and easy
    1990 indy trail bored.20over, ported and polished, cluched and geared, chaincase/brakes/jackshaft from 93 xlt, headlight cover, black skid plate, blue running board trim, fox shocks, 2 in powermadd riser, fly bars/barpad,1 in lug track, xtra 10 rear, and edge seat and tank.

    06 iqr 440, c&a skis,600ves tag bars cobra windsheild rev 440 seat-sold
    04 proxr 440/700

    watercross sleds 05 xcsp with a 500 crankshop mod motor with twins running on vp 110
    and a 01 xc with a stock 600 ves and some homemade tweeks

  8. #8
    Member
    This user has no status.
     

    Member #
    8660
    Join Date
    Sep 2005
    Posts
    46
    I which the Polaris shop manual discribed it that way, i was following that. It was the first time I pulled this motor. I have pulled many indy and xlt engines. Live and learn.

    Thanks for the in put guys!

  9. #9
    Junior Member
    This user has no status.
     

    Member #
    64122
    Join Date
    Jan 2018
    Location
    Dansville, NY
    Posts
    1
    Polaris91 I'm replacing an engine in a 2002 XC Sp with my boy. We can't get the thing aligned up properly to the bolt heads. Would you please explain in further details your technique in getting the engine back in? I didn't understand where or what god bracelets are or "bulkheads". Thanks for your help on this.

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. installing a polaris shorty seat on an 02 edge
    By xcsp_rider in forum General
    Replies: 21
    Last Post: 12-30-2010, 08:52 PM
  2. 2011 800 cfi engine HP dyno
    By 500EFISKS in forum Polaris
    Replies: 27
    Last Post: 09-27-2010, 12:12 PM
  3. installing an edge skid
    By polarisorbust in forum Polaris
    Replies: 2
    Last Post: 03-24-2010, 03:12 PM
  4. 600 ves Polaris edge engine for sale
    By StealthyJim in forum Parts and Accessories
    Replies: 0
    Last Post: 02-24-2006, 04:14 PM
  5. I need help installing skins on my 550 Edge
    By jssbastiat in forum Polaris
    Replies: 6
    Last Post: 02-05-2006, 07:21 AM

Search tags for this page

loose motor mount on polaris xcsp
,
pulling motor from 2005 polaris xc
,

xc 800 motor install

Click on a term to search for related topics.