Bad Piston in 600 Indy
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

Bad Piston in 600 Indy

This is a discussion on Bad Piston in 600 Indy within the Polaris forums, part of the Brand Specific Snowmobile Discussion category; I had a piston go out on my 2013 600 Indy over the weekend. Has only about 2500 miles on it. Also took out the ...

"); }
Results 1 to 4 of 4

Thread: Bad Piston in 600 Indy

  1. #1
    Junior Member
    This user has no status.
     

    Member #
    37229
    Join Date
    Dec 2011
    Posts
    7

    Bad Piston in 600 Indy

    I had a piston go out on my 2013 600 Indy over the weekend. Has only about 2500 miles on it. Also took out the cylinder also. It is the one on the Mag side. I've been told to replace the engine wiring harness along with new piston & cylinder. I'm just looking for some in put so it don't happen again.
    Attached Images Attached Images      

  2. #2
    Senior Member
    This user has no status.
     

    Member #
    12399
    Join Date
    Feb 2006
    Location
    WNY
    Posts
    2,547
    Not good. What does the wiring harness have to do with the piston issue....just curious?

    Sent from my moto z3 using Tapatalk
    Polaris...it IS the way out!

  3. #3
    Junior Member
    This user has no status.
     

    Member #
    37229
    Join Date
    Dec 2011
    Posts
    7
    I was told there may be a short in there someplace. Friend of mine was working on one last year and while the computer was hooked up to sled it was fine. while testing the one injector on mag side did lose pressure sometimes. He replaced the wiring harness and it was fine.

  4. #4
    Senior Member
    This user has no status.
     

    Member #
    12399
    Join Date
    Feb 2006
    Location
    WNY
    Posts
    2,547
    I see. I suppose an injector shorted may lead to a fueling issue and cause a lean condition but you would have felt a running issue long before the piston gave way in my opinion. I think you have an air leak someplace. I would check seals, throttle body boots etc before you fire it up as to not waste rebuild money. Let us know what you find.

    Sent from my moto z3 using Tapatalk
    Polaris...it IS the way out!

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 5 days before group ride, I find bad piston
    By Blackcat in forum Arctic Cat
    Replies: 13
    Last Post: 02-20-2008, 02:07 AM
  2. Indy 500 Bad Piston, Help
    By Homey in forum Polaris
    Replies: 5
    Last Post: 01-31-2008, 11:20 PM
  3. 1998 yamaha SRX 700 bad piston
    By Yuriy in forum Yamaha
    Replies: 8
    Last Post: 11-11-2007, 07:39 PM
  4. 1998 Yamaha SRX bad piston
    By Yuriy in forum Yamaha
    Replies: 0
    Last Post: 11-06-2007, 12:09 AM
  5. piston question i think this is bad
    By indy500efi in forum General
    Replies: 4
    Last Post: 03-31-2007, 10:59 PM