98 Indy 500
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

98 Indy 500

This is a discussion on 98 Indy 500 within the Polaris forums, part of the Brand Specific Snowmobile Discussion category; Howdy all! This may be somewhat of a lengthy post, however I'm just trying to give as much info as possible. Bought a barn stored ...

"); }
Results 1 to 5 of 5

Thread: 98 Indy 500

  1. #1
    Junior Member
    This user has no status.
     

    Member #
    26331
    Join Date
    Mar 2009
    Posts
    1

    98 Indy 500

    Howdy all! This may be somewhat of a lengthy post, however I'm just trying to give as much info as possible. Bought a barn stored 1998 Indy 500 at the end of last season for my son. Sled had been sitting for a number of years. When I got it home, I first pulled the motor and carbs, cleaned the engine compartment (just because I'm meticulous about this) and drained and cleaned the tank. I replaced ALL seals and gaskets, compression tested 121 and 122 on cylinders. All new fuel lines, new in tank brass filter, new coil pack with new plugs and boots, new voltage regulator, then had carbs ultra sonic cleaned. Put back together and it fired right up. But now it has developed a big after running for about 10 minutes, to the point it won't move. Will idle all day, but once it's warm and you apply throttle, it just bogs and won't t move. Has anybody had this experience? Any info and insight would be GREATLY appreciated!

  2. #2
    Senior Member
    This user has no status.
     
    Polaris_Parts_MN's Avatar
    Member #
    22421
    Join Date
    Oct 2008
    Location
    Minneapolis, MN
    Posts
    2,712
    Did you replace the fuel inlet needle float valves in the carbs? I'm wondering if they are not closing, and allowing gas to continue to flow into the carb bowl and load up the engine.
    2003 Edge X 700 Black/Yellow
    SLP pipe/can, SLP Air Horn and Boost Bottle, VForce 3, Rush skis, Geared & Clutched, Electric Start, Reverse, IQ seat with Fusion trunk/taillight, Camoplast Cobra 1.375"

    1999 Polaris XC 500
    SLP silencer, Boost Bottle, Geared & Clutched, on-the-fly adjustable Fox dual remote reservoir front track shock,
    Fox front shocks with triple rate springs, IQ seat/tank and LED taillight, Camoplast Predator 1.25"

  3. #3
    Junior Member
    This user has no status.
     

    Member #
    49337
    Join Date
    Feb 2016
    Posts
    12
    Check the fuel pump? May be weak and supplies enough gas at idle, but not at WOT.

  4. #4
    Senior Member
    is Wishing I could ride a twin
     
    madcow's Avatar
    Member #
    493
    Join Date
    Mar 2002
    Posts
    8,842
    bogs and smokey if you run it on a track stand how does it run? what are engagement rpms? wide open rpms? clutches in good shape? could be broken primary spring, bad secondary spring. the stock red one should be tossed out for a black spring any how.

    did the carbs get synced? chokes set right?
    your mommas so dumb she threw a rock at the ground and missed.

    your mommas so fat when GOD said let there be light he asked her to move.

    nothing goes like 3 holes!!
    Aaen Performance!!!!
    High performance engineering
    millennium technologies
    brtech hoods
    price performance

    Got Speed Racing
    320-629-4889

  5. #5
    Junior Member
    This user has no status.
     

    Member #
    68552
    Join Date
    Sep 2018
    Location
    Canisteo, NY
    Posts
    13
    Make sure your choke plungers are set correctly.

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •