2003 rmk 800 engine issue
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

2003 rmk 800 engine issue

This is a discussion on 2003 rmk 800 engine issue within the Engine forums, part of the The Performance Tuning Shop category; I have a 03 rmk 800, it starts up and runs well then you go for a ride for about 15 min or so it ...

"); }
Results 1 to 3 of 3

Thread: 2003 rmk 800 engine issue

  1. #1
    Junior Member
    This user has no status.
     

    Member #
    72852
    Join Date
    Jan 2020
    Posts
    1

    2003 rmk 800 engine issue

    I have a 03 rmk 800, it starts up and runs well then you go for a ride for about 15 min or so it completely loses power and the only way you can get back home is to use 1/4 throttle or less. So i've done a complete engine top and bottom rebuild, checked plugs and put on a new coil. I'm not sure what the issue is and need some ideas, Thanks.

  2. #2
    Senior Member
    is Wishing I could ride a twin
     
    madcow's Avatar
    Member #
    493
    Join Date
    Mar 2002
    Posts
    8,842
    have seen stators go bad and act like that.
    have seen fuel pumps go bad and act weird when driving but you would get gas leaking into the engine overnight.
    your mommas so dumb she threw a rock at the ground and missed.

    your mommas so fat when GOD said let there be light he asked her to move.

    nothing goes like 3 holes!!
    Aaen Performance!!!!
    High performance engineering
    millennium technologies
    brtech hoods
    price performance

    Got Speed Racing
    320-629-4889

  3. #3
    Senior Member
    This user has no status.
     

    Member #
    42349
    Join Date
    Nov 2013
    Location
    Prairies
    Posts
    122
    check your coolant temp sensor. You might be tripping it and going into limp mode

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •