Search Results - Snowmobile Fanatics - Snowmobile Forum
Close
Login to Your Account
Snowmobile Fanatics - Snowmobile Forum - Powered by vBulletin

Search:

Type: Posts; User: polaris_ben

Page 1 of 2 1 2

Search: Search took 0.03 seconds.

  1. Replies
    7
    Views
    271

    Edit- after some research it looks like that...

    Edit- after some research it looks like that puller is for the liberty twins, I would still buy that kit and just buy the correct puller separately. you can't beat that price. A good puller should...
  2. Replies
    3
    Views
    161

    ACS is alternator controlled switch and it was...

    ACS is alternator controlled switch and it was used on 93 and newer so you shouldn't have it. I had the same problem with mine and found it was the brown wire (chassis ground) terminal connection...
  3. Replies
    7
    Views
    271

    If you do decide to buy the tools, you can get...

    If you do decide to buy the tools, you can get everything you'll need to service the Primary for $161.89 at the link below. This will work on your P85 clutch. ...
  4. I just had a similar problem with indy 500 EFI. ...

    I just had a similar problem with indy 500 EFI. Had me scratching my head, thought it was fuel or clutch related. Come to find out it was the PTO side spark plug boot was barely making a...
  5. Replies
    1
    Views
    98

    you'll need a different chip/ROM ID. Not sure...

    you'll need a different chip/ROM ID. Not sure where you would find one. If you're on Facebook, there's a really good group on there dedicated to the early Polaris EFI's that would be able to help...
  6. Replies
    154
    Views
    40,085

    Mine wouldn't work at first either. I found out...

    Mine wouldn't work at first either. I found out that I had to open up the drivers in their own window. Then it worked just fine. I'm running windows 7. It seems that you need to do this because the...
  7. Replies
    154
    Views
    40,085

    Digikey should still have them. Check out the...

    Digikey should still have them. Check out the link below, it should tell you everything you need to know. It's where I got the information I needed to get mine to work.

    Polaris RXL and Indy 500...
  8. Replies
    14
    Views
    3,016

    It sounds like the exact same issue that I was...

    It sounds like the exact same issue that I was having with my 92 500 EFI. It would run fine for about 5 to 7 minutes or so and then just die. If you let it sit for about 10 minutes, it would start...
  9. Replies
    1
    Views
    708

    Hopefully this will get you the answer you're...

    Hopefully this will get you the answer you're looking for. The 582 & 583 are used from 91 to 93. I would just stick with the one you have in there now if everything is functioning properly.
  10. Yes those are vents and should have tubes on them...

    Yes those are vents and should have tubes on them to route the excess fuel to a safe place (away from hot metal). Your excess fuel is coming from the float bowls overfilling which could explain your...
  11. Replies
    20
    Views
    4,118

    Check to see If your sled has a fuel enrichment...

    Check to see If your sled has a fuel enrichment switch on it. This could also be feeding the ECU the wrong info if the switch has a bad connection or is disconnected. In the "off" position, the...
  12. Make sure your alternator is working correctly,...

    Make sure your alternator is working correctly, do an output test. You can still get a regulator/rectifier on ebay. it is the 4060095 for the RXL but it will work. Here's the link POLARIS PURE OEM...
  13. Replies
    20
    Views
    4,118

    Not sure if you have any kind of service manual...

    Not sure if you have any kind of service manual to reference but you can download a pretty good one on this site that has helped me with my EFI. At the top of the home page, click on communities,...
  14. Replies
    20
    Views
    4,118

    you said that the primary is currently off, so...

    you said that the primary is currently off, so you're running it with no load on the motor? I would put the clutch back on (even if it isn't in the best shape) and run it to see if it acts...
  15. Replies
    15
    Views
    2,928

    It should be pretty tight. Go to the first link...

    It should be pretty tight. Go to the first link below and look at pages 9.10 and 9.11. This should walk you through on how to tension it and align it. The second link will get you to the home page....
  16. Replies
    15
    Views
    2,928

    Yes, you would have noticed something if there...

    Yes, you would have noticed something if there was a leak and you'd have to have a gaping hole in order for it to act like it's acting. I still think that something is slowing the fuel flow to that...
  17. Replies
    15
    Views
    2,928

    I was just thinking that you could also have a...

    I was just thinking that you could also have a vacuum leak if you just replaced the carb boot and it's not sealed somewhere so it may be sucking air. Just make sure it has a good seal
  18. Replies
    15
    Views
    2,928

    I would definitely focus on the recoil side carb....

    I would definitely focus on the recoil side carb. Good luck
  19. Replies
    15
    Views
    2,928

    No, being one notch off wouldn't affect it that...

    No, being one notch off wouldn't affect it that much. The two plugs with dark liquid are what I would expect to see after running it on half choke, the dry/clean plug is the cylinder giving you the...
  20. Replies
    15
    Views
    2,928

    Check your spark plugs, I'm thinking it may just...

    Check your spark plugs, I'm thinking it may just be one cylinder giving you a problem. Look for one that is lighter in color than the others. This should be your problem cylinder. The float could be...
  21. Replies
    15
    Views
    2,928

    I'm assuming this has the Mikuni slide type carbs...

    I'm assuming this has the Mikuni slide type carbs on it. It sounds like you're not getting enough gas to the mid/full throttle. Sounds like the main jet is being restricted. By "choking it" on the...
  22. Where can I find a diode pack, Radio Shack? Any...

    Where can I find a diode pack, Radio Shack? Any idea on why Polaris doesn't give you everything you need in this regulator kit if it is supposed to replace the old regulator/rectifier? Is there a...
  23. Anyone know how to wire in a new 2 wire volt reg on batt charging circuit? 92 500 EFI

    My 92 500 SP EFI originally had a volt reg with a p.n. 4060092 (3 wire) which is no longer available. the new p.n. is 2203873 which is a 2 wire (a red and a yellow wire to one plug). I have 2 wires...
  24. VR 2203873, 3 wires to 2 wires, 92 500 EFI

    I just purchased the newer replacement voltage regulator for my 92 EFI sp and of course it is different. The old one had grey and a grey/white wire from the coil going into it and a red out to the...
  25. Replies
    6
    Views
    1,767

    Thanks for the info. I give the output test a try...

    Thanks for the info. I give the output test a try tomorrow.
Results 1 to 25 of 28
Page 1 of 2 1 2