Snowmobile Fanatics banner

1 - 17 of 17 Posts

·
Registered
Joined
·
318 Posts
Discussion Starter · #1 ·

·
Registered
Joined
·
347 Posts
HOW MANY WATTS ARE YOUR HID,S....IVE GOT A 06 FUSION WITH BATTERY,AND 55 WATT HIDS,AND WHEN IDLING THEY KILL THE BATTERY,AND BEGIN TO FLICKER?I DONT UNDERSTAND HOW YOU GET ENOUGH POWER TO GET THEM LIT AT IDLE??CAN YOU EXPLAIN?DOTHEY FLICKER?AND THEY RUN ON 12V DC NOT A/C?
 

·
Registered
Joined
·
318 Posts
Discussion Starter · #4 ·
35w hid / no problem at idle - solid 12V DC on idle / no flicker --> i have them on my 800 as well - do you have analog ballasts or the digital slim ones? digital slims are better at managing fluctuating input -- they are good from 9-14v or something
 

·
Registered
Joined
·
610 Posts
I put some HID's in my motorcycle over the summer and I loved them. I'd like to get them in my sled but I'm completely lost on how to install them in a sled without a battery. Can someone explain this to me assuming I know absolutely nothing about electrical components. I'm not very experienced with electrical stuff. Pictures of things would be even better!
 

·
Registered
Joined
·
414 Posts
im pretty sure it only works (well) without a battery if your sled is that chassis style because of how they are wired, they dont really die down with low idle. for instance...no worky on my 04 prox, worky on your 07 and my friends 09 dragon.
 

·
Registered
Joined
·
318 Posts
Discussion Starter · #8 ·
I get mine from a guy I found on kijiji - but the next best place I found them was at

Www.vvme.com

If you do buy - get the digital slim ballasts
 

·
Registered
Joined
·
610 Posts
So i still have about 2 months until snow falls and I want a project for my sled. I think I'm going to try and get this to work, there has to be a way.

What if I were to buy a wiring harness from another Polaris sled that has electric start. I can rewire my sled with that and put a battery in my sled that the stator will keep charged. I can put a switch in before the hi/lo switch to turn off the headlights when i am letting the sled warm up or idling for a long period. I can also put in a relay (from my understanding of a relay, they only send the current if it reaches a certain voltage?).

How do i know if my sled has ac or dc current? My understanding of dc current is it is a constant current (which the hid's need) and ac fluctuates in current level. Is this correct? I'm guessing my sled must have ac since the headlights dim at an idle.

I'm still new to this electrical stuff but it's fascinating to me. Any help would be appreciated.
 

·
Registered
Joined
·
18 Posts
Hey, how did you get your hid's working in your sled? i have no battery either and i tried them and i have tried adding certain parts that i had bought from radioshack...besides what your order with your hids what did you have to add o from it??
 

·
Registered
Joined
·
318 Posts
Discussion Starter · #11 ·
didnt have to add anything -- there is a block in the middle of the lights that polaris supplies, they use it for their projector kit add on -- i justed used the block to supply my 12v DC -- thats all
 

·
Registered
Joined
·
15 Posts
i tried to put them on an 03 arctic cat batteryless just plug and play they flicker, tried resisters that didn't work. then i was told that a sled runs on ac and need to add a rectifier to change from ac to dc i tried that. that fried a ballast. don't know what to do now.

also reading specs on ballast the out put is 8.5 VOLTS AC
 

·
Registered
Joined
·
318 Posts
Discussion Starter · #14 ·
you might have had it backwards -- or the wrong type
 

·
Registered
Joined
·
2,422 Posts
Also on the rectifier you have to make sure its a full-wave rectifier or it won't work correctly.
 

·
Registered
Joined
·
463 Posts
shnill said:
I get mine from a guy I found on kijiji - but the next best place I found them was at

Www.vvme.com

If you do buy - get the digital slim ballasts
shnill. i ordered a set of hid's from vvme.com for my06 900... and the actual bulbs are loose in the housing that they are mounted in, if you opened the box and took the bulbs out of the packaging and shook the whole bulb assembly the actual glass tube that is the bulb rattles a little!! just wondering if you have experienced this??? both bulbs in my kit were like this btw!! did i read somewhere that you removed the the rounded reflectors at the end of the bulbs??? thanks dano
 
1 - 17 of 17 Posts
Top