Snowmobile Fanatics banner

1 - 7 of 7 Posts

·
Registered
Joined
·
384 Posts
Discussion Starter #1
My buddy is selling the wrecked phazer and bying this sled. The owner says that it has a problem with blowing head gaskets. He replaced the head and it still did it so I'm leaning towards the cylinder being warped.I noticed its a piston port motor and it is piped. I'm just wondering what problems if any we will run into since I'm his sled mechanic. Is it a good sled or did they have problems like the later 650"s?
 

·
Registered
Joined
·
1,407 Posts
good luck on this one i posted the same topic and got like 2 replies,from what i understand people had mixed feeling about this year and model some said it was good and others say it was junk
 

·
Registered
Joined
·
5,400 Posts
The 600 is the precursor to the 650 only will less bore. However you should find it reliable, the 650's didn't have issues, but those caused by irresponsible owners piping without jetting or jetting improperly.
 

·
Registered
Joined
·
384 Posts
Discussion Starter #4
I thought the later 650's had a crank bearing problem.
 

·
Registered
Joined
·
3,029 Posts
no 650's were actually quite reliable in stock trim, its when guys started fooling with them pipes etc etc, no crank bearing issues. They can run pipes if setup properly and still be pretty reliable as well. As triple 650 said, it should be decent.
 

·
Registered
Joined
·
345 Posts
pm me if you are looking for any parts for it. i am parting a 600 out.
 

·
Registered
Joined
·
126 Posts
I have a 610 rebiult, 500 mi, al wisco, and new everything u can think of, $800
 
1 - 7 of 7 Posts
Top