Snowmobile Fanatics banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
having a problem with my sons 1995 polaris indy 500 liquid blew the clutch side piston pulled it apart found it was 60 over with wiseco pistons put a new one in put it back together had carbs check stock jetting is 300 it had 280 put 320 in sled runs good but when you rev it up the rpms stay a 2200 if l turn the idle screws out it comes down and will idle at 1400 if you shut the sled off and wait 5 minutes it is hard to start and have to give it choke when you get it started it idles about 800 rpms any suggestions thanks
 

·
Registered
Joined
·
1,236 Posts
polarishelp said:
having a problem with my sons 1995 polaris indy 500 liquid blew the clutch side piston pulled it apart found it was 60 over with wiseco pistons put a new one in put it back together had carbs check stock jetting is 300 it had 280 put 320 in sled runs good but when you rev it up the rpms stay a 2200 if l turn the idle screws out it comes down and will idle at 1400 if you shut the sled off and wait 5 minutes it is hard to start and have to give it choke when you get it started it idles about 800 rpms any suggestions thanks
not 100% sure but dont you want them to idle 1500-2000?
 

·
Registered
Joined
·
632 Posts
nothing wrong with 2200 rpm idle.
 

·
Registered
Joined
·
506 Posts
Sounds like you just need to run the sled a little. It sounds like you rebuilt one cylinder, which is fine but you need to run it some to break it in. As far as Idle rpm, they always idle faster at startup, after it warms up the idle will lower some, often after a blip on the throttle. 1400 to 2200 sound OK for idle speed it just personal preference.
 

·
Registered
Joined
·
67 Posts
Does it have flat slides? If so check them for cracks or see if they are broken. It sounds like too much air
 

·
Registered
Joined
·
1,236 Posts
actually we cant even make ours idle under 1000 they just choke themselves out even after they have warmed up
 
1 - 6 of 6 Posts
Top