Snowmobile Fanatics banner

1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
hello to all, im having trouble with my ultra,it seems to be running rich, i think.It has already been jetted 2 sizes leaner on the main jets, havent touched anything else yet, itseems rich just cruising around at slower trail speeds,it takes a awhile for it to clear out after driving slow no power when i crack the throttle. I dont really know how to tune the 1/4 to 1/2 to 3/4,throttle thats where it seems rich. any help would be greatly appreciated, thanks to all
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
The plug color seems to be nice and brown on all three, the pilots are stock, and the clip is second from top. Like i said it SEEMS like it is running rich,ive never owned an ultra before, i dont know if this is normal or not. Been reading alot about it though, is there a certain way to bypass that muffler thing,what ever it is called. mine is taken off and i am not sure what was done with the wires,arent they supposed to be wired a certain way to bypass it? thanks for any replies, thanks
 

·
Registered
Joined
·
318 Posts
I know that when you put pipes on you have to bypass the exhaust temp sensor that is in the single pipe muffler.

If you go to SLP's website and look at their instructions for the 680 ultra pipes, they show you how to disconnect the computer for this. It is right next to the 12 volt regulator beneath the keyswitch...
 

·
Registered
Joined
·
1,056 Posts
Main jets won't do anything for less than 3/4.

Take out your jet needles and make sure they are the right size. How many miles are on your sled? You may want to replace the needle jets too.

Remove the carbs and check to make sure your float levels are adjusted before doing anything else.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
My needles are stock according to the sticker on the hood. I dont know how to adjust the floats,can someone explain how it is done and what the specs are on it. Thanks for the replys, really want to figure this problem out, thinking of buying pipes but dont want to waste the money on them if the machine isnt going to run right anyway so please help, need to figure this out thanks again
 

·
Registered
Joined
·
2,067 Posts
Originally posted by crazykid
[br]. I dont know how to adjust the floats,can someone explain how it is done and what the specs are on it. Thanks for the replys, really want to figure this problem out, thinking of buying pipes but dont want to waste the money on them if the machine isnt going to run right anyway so please help, need to figure this out thanks again
Pull the carbs off, take the bottom off. Turn the carbs upside down and make sure the arm is parallel to the base of the carb.

Did you check the chokes? These dump raw fuel into the carb body. If the plungers aren't set correctly to stop fuel flow it will make it run rich. Then it seems to clear up at higher speeds because you went down 2 sizes. BTW, what did you put in there?

Bryan
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
Well i think i figuredout what the problem is, my mag side coil is intermittent i think. Is this possible,for a coil to be intermittent? It sems to be firing only once in awhile,but only sometimes, it sounds like a rich condition but i guess it could be the coil, what do you guys think? Iam lookin for a coil to swap out and find out for sure.
 

·
Registered
Joined
·
1,056 Posts
Dropping a cylinder intermittently is going to really sound odd and feel so too. You would instantly know it. Why do you think your coil is "intermittent"? Have you checked the wire running to the coil from the magneto?

Here are the specs for your carbs:
pilot jet 40
air screw 1 turn
jet needle 6DH8-2(Clip position is in the second slot)
needle jet P-4 (247)
cutaway 2.0

Take your carbs off and verify all of the above.
 
1 - 9 of 9 Posts
Top