Snowmobile Fanatics banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
hi guys new here so please bear with me i have a 1998 xcr 700 indy with a big bore kit and porting done by flannery motors in wayland mi with a digatron dt-34 egt and tach set up sled is awsome the problem is when i am running and decide to punch it at high rpms the coolant comes out of the tank and blows back on me just put a new cap on and thats not the problem just wondering if you might have any thoughts thanks in advance
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thinksno said:
Water pump is heading south fast. You will need a new mechanical seal and bearing.
just talked with mechanic at peacock ltd in baldwin mi polaris dealer they said coolant filter needs to be changed . if so where is it located and how does that sound to you guys
 

·
Registered
Joined
·
2,317 Posts
Coolant filter? Is that like blinker fluid?

Never heard of coolant filter.[Disappointed]

Seeing your sled is a mod,maybe it has a filter.[:)]
 

·
Registered
Joined
·
453 Posts
I'm pretty sure the filter is inline BEFORE the heat exchanger, right side of the sled, below the exhaust can...pull off the two hose clamps, replace with a strait connector, viola, done.
 

·
Registered
Joined
·
591 Posts
replace the check valve and filter, it is inline on the 1/4 hose that comes off of the bottom of the coolant tank,I have had two sleds that did this, and that fixed it both times. The parts should only be around 10 bucks.
 
1 - 9 of 9 Posts
Top