Snowmobile Fanatics banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
hey guys!! so I'm going to be buying another snowmobile! this is a 1998 polaris xcr600 with a ultra spx 680 motor. (atleast as far as i can tell, it has spx carbs, and spx pipes) only issue that seller SAYS he knows of, is that some how or another coolant is getting in the case. seller told me he had already replaced orings on heads hoping that was the cause. but it wasn't. so im thinking that leaves base gasket, or water pump. I got sled for $600 so, i guess worse case scenario i bought spx carbs and pipes, and a plethora of other parts to use on my 96' ultra. so, a couple questions. is there any ride difference between the aggressive chassis, and the wedge? or will it be the same ride? and would you guys agree that most likely, would be a base gasket leak, or water pump? thanks for all your help guys!! :)
 

Attachments

·
Registered
Joined
·
15 Posts
Discussion Starter · #2 ·
ok. so i thought that xcr600 had the monoblock motor.... but now im seeing pictures of xcr600's with individual jugs. and they look JUST like the ultra motor... with out having the sled in front of me, is there any tell tale signs as to if this has really been ultra swapped? or if its just the xcr engie? thanks guys :)
 

·
Registered
Joined
·
15,722 Posts
Xcr "sp" 600's since 96' had that motor. So its either a 680 or a 600. You have to figure that out. I bet the water pump seal is seeping into the block..... Look to pay up to get that fixed :(
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
ahhh ok. but the 600 jugs should not be stamped ecp68l tho. right? so should be faily easy to tell the difference? and also, why do do you say "look to pay up to get that fixed"? am i missing something? seal is $30 then gaskets... thanks for your help :)
 

·
Registered
Joined
·
15,722 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
oh ok, what else is it that leaks? so i can make sure i take care of it. and thanks for the pictures! :) I assume the the pl03 is the spx? again, thanks guys! :) should be picking the sled up tomorrow. if it all goes well. also, does anyone know where to find the rebuild kits for the water pump? everywhere i look, it just says unavailable.
 
1 - 6 of 6 Posts
Top