Snowmobile Fanatics banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1999 500 XC, i just put new gas in it, new plugs and stuff, and it wont start. I have no idea whats wrong. It started earlier like a month ago, then it had a big backfire, and it hasnt started since. it almost starts, you can get it almost going, then it dies. then i takes a while to get it to almost start again. I have checked everything i know, including the fuel on and off button. do you guys know what is wrong?? thanks!
 

·
Registered
Joined
·
1,099 Posts
my xlt did that, i had gas in the cylinders, i pulled the drain bolts out (front of engine,under exhaust) and pulled the lugs so it would air out, but got impatient, and started it, damn it backfired hard!!!!!
 

·
Registered
Joined
·
11,943 Posts
Check the skirts on the pistons. If they break off, it will backfire when you try start it. Take off the carbs, carb boots and pull the reeds out then you can see the pistons through the reed block.

 

·
Registered
Joined
·
243 Posts
I don't know what you've done already, but start with the basics. Check compression, fuel delivery, combustion air, and spark and see what is missing from those.

You don't have to believe everything you think!
 

·
Registered
Joined
·
608 Posts
I know what you are talking about HotRod. I had a triple with triple pipes and one of the pipes had a mouse nest in it. It would run on the other cylinders but it would backfire from the one. The first thing I would check are the spark plugs and drain the fuel out of the carbs in case there is water in them. Let us know what you find.
 

·
Registered
Joined
·
114 Posts
Yes i agree with razorsharp. Check the airbox and make sure u do have spark as well. Make sure its even getting gas!

Ski-Doo- Better than Polaris and faster than Arctic-Cat
 

·
Registered
Joined
·
55 Posts
First of all check that you got good snappy blue fire all the time and that it isn't missing. Then take a compression test i had a engine that would not start so i put tons of oil down the plug holes and it started smoked but started. If you got good compression probley atleast 110 psi. Check your gas see if there is any water in it and clean your carbs
 
1 - 10 of 10 Posts
Top