Snowmobile Fanatics banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Well id just liek to say hi to every one on this fourm, i just signed on. I have a problem with my 2000 xc 600, it doesnt seem to rev out liek it should. It tops out at around 7200 or so, some days are better then others. some days it only hits 7000 some days 7400. ! know what one of the problems was the little diaphrams on the top of the cylinder the cone out towards the lights were dried and cracked with holes. They were for the power valves i think and work off a suctions, when i replaced these it made a world of difference but it still doesnt rev out like my 93 indy 500 wich its around 8600 rpms. This sled was bought used for cheap b/c it had a bad crank. we bough it then the dealer we bough it from put a new crank in. this dealer is a small business that deals in used veichiles and off road stuff. the only things i can think of is that the dealer govened the sled down so that it wouldn't pop as soon as i got it. the dealer said when he got it it had a bad bottom end noise and the oil injectors were turned up to help silence the noise. well thats about it. i would really appreciate ur responces, withing the next 2 weeks im gonna pull it out and check the compressions on the cylinders, then its probally going out of town 2 get it fixxed if i cant get it to work right. thanks alot guys. its also pretty harsh on fuel compaired 2 my 93 500, but this could be normal, i useally burn about 10-15 gallons of fuel perday ever day i get on weekends thanks i really appreciate ur replays. thanks
 

·
Registered
Joined
·
777 Posts
first off,do not go back to that dealer again
,Anyone thats says turning up the oil consumpiton to get rid of a crank noise,is full of $hit,
i hope he had the valves out to clean them,if they are seized in,it won,t rev up and make full power,
that has a square primary clutch spring,look good at it to see if its broken,that will also cause low rpms.compression should be 120lbs
it should run at 8250 rpms
just something to look at
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
yeah thanks alot, i called this guy today and he said try a different belt for my sled, he also sugested that its in the clutching, i have no clue with snowmachine clutchs so i think im gonna do some serious reading first or just bring it to a dealer or this guy and tell him 2 clutch it, thanks alot keep the replays coming on ne other possible problems
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
today i checked my compression today and its at 120 psi per cylinder, they belt is good and i put it on blocks and it only revs out at 7000 rmp. i think its in the clutching, would a performance clutch kit fix this, i was thinking on getting an epi clutch kit form royal distubition or form my polaris dealer. what do u guys think?
 

·
Registered
Joined
·
2,729 Posts
I may be wrong, but i would say with the sled up on a stand, it should rev out until it hits the rev limiter built into the cdi box. Reason behind my madness is because there is no load on the drivetrain. Hmmmm or is there, check the drive train for bad bearings, idler wheels and correct track tension/alignment. Make sure your belt is the correct length and that it is not too short. Another idea that i thought of if the dealer didnt want you to have very many RPM's is to check the throttle slides in the carbs to be sure they are fully opening. Its possible that they may have even forgot to adjust the throttle cable when they reassembled everything.
 

·
Registered
Joined
·
48 Posts
It could be the stator, my brother's 98 xc 700 would go good up to about 7-7400rpm and stay there, but his also would drop after gunning it for a bit.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
well, right now its in my shed with 2 other sleds so im cramped 4 room. im pouring the pad 4 my own grage this weekend so ill have it withign next week so then im gonna move it in there and start ripping shit off, i was also told that if the flat slide carbs are dirty it will do that, i think im alos gonna rip my clutch apart if nothing els works. it just annoys me that my 2000 600 doesnt rev higher then my 93 500 and the 2000 is only a lil bit faster, i just want this sled 2 perform liek it should. thanks for the info
 
1 - 7 of 7 Posts
Top