Snowmobile Fanatics banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2000 arctic cat zr500 efi, but anyways there seems to be a couple problems:

First off, when i go to start the sled i pull the rope and it just pulls out easily with no drag at all. I can start is sometimes but i have to just kinda jerk the rope till it catches and then it will start.

Secondly, once i get it going about 40mph it just starts to rev really high and just seems like its going to blow up, so i have to creep it around, it almost fells like its not back shifting but i am not to sure.

And lastly it will not idle and good as it did last year but i think that is because i just put a hanlebar riser on and havent adjusted my new throttle extension. Thanks. Corbin
 

·
Registered
Joined
·
3,100 Posts
Pull the recoil apart, replace any worn out parts. Sounds like your secondary clutch isnt shifting correctly.
 

·
Registered
Joined
·
1,236 Posts
ya sounds like the pins in the recoil are broke or worn out, this allows them to slip by, either take it apart and fix or get a new one off the internet which every is eaisiest for you

not sure on your clutch problem, i just got mine goin
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
ok thanks guys and one more thing, if i just gun it right from a dead stop it really bogs out. i know its not the tps because i disconected that last year
 

·
Registered
Joined
·
1,236 Posts
BskidooC said:
Lean condition maybe.
possibly, but i just got done doin a topend on our ZR600 EFI, because it had a lowend bog, havnt been able to gun it yet, still tryin to break it in, but just putzin around it has more zip then it used to
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
dodgetruck2 said:
BskidooC said:
Lean condition maybe.
possibly, but i just got done doin a topend on our ZR600 EFI, because it had a lowend bog, havnt been able to gun it yet, still tryin to break it in, but just putzin around it has more zip then it used to
It probably doesnt need a rebuild because it just got new pistons, rings, and cylinders 400 miles ago
 

·
Registered
Joined
·
1,236 Posts
hopefully not, but you never know
 
1 - 8 of 8 Posts
Top