Snowmobile Fanatics banner

1 - 6 of 6 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Can anyone tell me what to watch for in these sleds? I have just made the switch to ski doo from polaris and any knoldge I can get would be awsome. Why does it beep twice when it first starts? It also has reverse. And it only reves out at 7500 rpm and dosent pull for an 800. 145 km tops. Can anyone give me some advice? Thank you in advance.
 

·
Registered
Joined
·
511 Posts
The beeping is the security system saying that the correct tether is plugged in I believe. Does the same thing on my 2002 Doo 700.

I can't tell you about clutching, but there is a wealth of Doo knowledge on Dootalk (not trying to take away from SF, but there is a LOT of great info there).
 

·
Registered
Joined
·
4,823 Posts
Check those carb boots out! The aluminum ones are available for it my friend put them on his last year. The rubber ones tend to dry out and crack after a while.
 

·
Registered
Joined
·
511 Posts
TRICKPaint said:
Check those carb boots out! The aluminum ones are available for it my friend put them on his last year. The rubber ones tend to dry out and crack after a while.
I forgot all about that! Mine were ripping when I got my sled, so I replaced them with Boyesen Rage Cages - they are the ones with the aluminum boot.
 

·
Registered
Joined
·
646 Posts
The tether has to beep twice in order to run correctly.
 

·
Registered
Joined
·
55 Posts
The beep twice is the engine management computer confirming the proper d.e.s.s. tether/key is inserted and initializing of the system. As long as you hear this then it is working properly. Also, as to your speed or lack of.... before anything i would check compression especially if it has a lot of miles on it. Are plugs good? Does it bog at all or is it just lacking power all together?
 
1 - 6 of 6 Posts
Top