Snowmobile Fanatics banner

1 - 8 of 8 Posts

·
Registered
Joined
·
827 Posts
Discussion Starter #1
I'm about to pull the carbs on my XCR 800 for pre-season cleaning. I ran the stock 440 mains last year after buying the sled and rebuilding the engine.

I'm wondering what mains I can safely use for my elevation (1900 feet) and riding style (mostly trail riding, with a lot of wide open throttle). I rarely ride in real cold weather (-20 c at the coldest).

It ran pretty good last year but I think it should have a little more power. The plugs were a little dark in my opinion.

I'm thinking about putting 420 mains in it, but I would appreciate some input.

Also thinking about ordering an EPI clutch kit. Has anyone installed one on an XCR 8?

Any input is appreciated.
 

·
Registered
Joined
·
8,842 Posts
I ran 420 for a lot of miles, others are down to 400's for trail riding with some wide open runs. I would try 420's and keep an eye on the plugs.

for the epi kit the stock setup works pretty well. I changed a lot of trail sleds to a 22-40 gearing and some of them added a hot seat kit and others just left stock or added some weight in the primary and for seat of the pants they all felt close.
 

·
Registered
Joined
·
61 Posts
hey madcow you have any experience with ufo in a 96 ultra with slp pipes im running real rich at ide 17.5 pilot at about a quarter turn out any more and idle hangs slp needles at 2nd from top and power reeds also any input would be great
 

·
Registered
Joined
·
827 Posts
Discussion Starter #4
Thanks Madcow, I appreciate the help. I rode in real cold weather a couple times last year, and it seemed like the sled ran the best at those temps. So I assume it's a little rich.

I will try the 420 mains and see what happens. I might have to stay home if it's too cold lol.
 

·
Registered
Joined
·
8,842 Posts
hey madcow you have any experience with ufo in a 96 ultra with slp pipes im running real rich at ide 17.5 pilot at about a quarter turn out any more and idle hangs slp needles at 2nd from top and power reeds also any input would be great

I run ufo's on my 1000 and I like them and they do fatten up the idle circuit. but 17.5 sounds a bit small for a pilot jet, if stock is 35 I would go to like a 25 and see what happens,
the idle is hanging up because you are to lean, does the sled ever pop out the exhaust like a backfire or have a bog when you hit the gas from idle?
 

·
Registered
Joined
·
61 Posts
no poping very slight bog ,when i had it set up before the ufo i was at a 25 pilot already they say to go down half of what i was using before on the pilot that would have been a 12.5 it was loading up at idle with a 17.5 if i turned out air screw just over half it would bog and idle would hang this thing is very rich at idle it burns your eyes and sucked down a half a tank of fuel in a half hour of riding in the fields when i first hit the throttle its slow to respond then very responsive in the mid range but fuel mileage sucks
 

·
Registered
Joined
·
827 Posts
Discussion Starter #7
Raybout. If you have a question to ask, maybe you should think about starting your own thread.
 
1 - 8 of 8 Posts
Top