Snowmobile Fanatics banner
1 - 5 of 5 Posts

· Registered
Joined
·
1,264 Posts
Discussion Starter · #1 ·
So my secondary clutch is staying open. I was doing some hill climbing yesterday and all of a sudden I stopped while moving and heard a *click*click*click*. I automatically thought my chain broke. I looked at my clutches and the secondary was wide open. I closed it and tried to get out of the hole I was in and it stayed open again. I did this several times. It has a new helix and red spring, both with about 700 miles on em. WTF is going on? I put the spring on the tightest setting but nothing. Any ideas?
 

· Registered
Joined
·
1,264 Posts
Discussion Starter · #3 ·
arcticcatmatt said:
spring slip out of hole?

I'd take it off and disassemble, inspect, then put it back together. 10 minute job if it is the typical cat external helix design
Yeah the spring is in the middle hole and is in the hole on the bottom. I am going to tighten it to the hole on the end or maybe even put my old spring back in and see what happens.Everything checks out though!
 

· Registered
Joined
·
1,264 Posts
Discussion Starter · #4 ·
So I took the secondary off and put the spring in the 2nd tighest hole. Everything was GREAT! I went up for a few runs in the steep powder on the side of a hill and no belt slippage. The 3rd time though, the clutch stayed open and I had to close it manually with my hands. This happened a few more times right after. On the ride home it ran just fine. WHAT is going on?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top