Snowmobile Fanatics banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
This is my first time with a forum. After veiwing this site, i had to give it a shot. Anyway, ive always been a ski doo fan and used to work at a dealership that sold polaris as well. Both great sleds in those days. i still own a 1997 summit 670 (which i still love) but i got a hell of a deal on a 2003 151. the one thing Ive been having trouble with is at the end of the day there is injection oil everywere! Its comming out of the tank cap. I bought one of those expensive little suckers and it didnt fix it. the dealer which i use knows of no problems. other people i ride with have the same problem on there 03's. Anyway, now i just ride with a rag tied around the cap to catch the oil and only fill it about three quarter full. Any one else know of this? PS. i believe that 2002 and 2003 models are the only ones that have the same part number on their cap.
 

·
Registered
Joined
·
2,304 Posts
Get a new OEM cap, and inspect the jug itself, mabey the thing is warpped or cracked

If it was my sled the oil injection would have been pulled the second I got it in my shop, they are all crap IMO
 

·
Registered
Joined
·
5 Posts
Did you figure out anything? I am having the same problem with my 02 mxz x800. It is definitely coming out of the cap. It seems to be coming up and out of the vent and then leaks out of where the yellow top piece presses into the main part of the cap. Why are these caps vented? I don't believe all sleds are vented? It makes quite the mess. Is there a fix? I have read about people replacing the cap and it still leaking.

Thanks
 

·
Registered
Joined
·
2,304 Posts
All tanks are vented, they have to be.
Maby check with a doo dealer and see if there is a recall/replacement cap
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Thanks for the reply trips67. Sorry it took me so long to reply back. Ive been away from the computer for a while. No, i havent got to the bottom of it yet. Ive talked to several other people that have had the same problem. No one has told me of a propper factory fix though. maybe we should just take teamnfg's advice and just pull it in to the shop and jerk the oil injection system out. it definitly wouldn't leak then. Ha Ha. No, seriously, ive kind of just ignored it for a while and put up with the leak but ill look back in to it more aggressively and ill write back in. Whats weird is my dealer says they have never heard of the problem but i sure know a lot of people who has had the problem. Later.
 
1 - 5 of 5 Posts
Top