Snowmobile Fanatics banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, just purchased this yesterday, it started on the 1st pull both times.

2015 Polaris Indy 120cc kids sled.


I cannot get it to start today. when I pull it, it acts the exact same as if I have the kill switch on..

I did move the governor spring from the fastest position to the slowest position, did I bump something that won't let it start now ?

any ideas ? the sled looks mint, rant great last night ...

I have the teather in, kill switch in the right position, the choke out ....


Any ideas ?



Are these generally tough to get started ?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
OK, I went out and tried again. I got it to start, the choke was all the way out. it ran for maybe 30 seconds, if I blipped the throttle, it seemed to rev ok.


Then it died. ...


Do you think its bad gas ?

gummed up carb ?

why did it start so easy when I went to look at it yesterday, do you think he put fresh gas in the carb bowl or something ?

When I was there, the choke was all the way out, engine seemed cold, but I didn't put my hand on it... why did it start so easy then ?
 

·
Registered
Joined
·
1 Posts
He probably had it all warmed up for when you showed up. Classic.

I would imagine a good place to start is plugs and fresh gas. If you're still having problems, reset the carb air screw (2 turns from bottom I think, but read up on it), and failing that, pull the carb and give it a good cleaning.
 
1 - 3 of 3 Posts
Top