Snowmobile Fanatics banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
i have a j.d. trailfire that is really hard to start. once i do get it started up it doesn't want to stay running unless i hold the throttle open some. then when i go to take off it is like it is built up alot of gas and boggs real bad when i take off. it will continue to bogg till about 10mph then it will take off. any ideas? i have cleaned the carb on it. does anyone know where the clip should be on the needle? what about what size jets shoudl be in it? any help would be appreciated.
 

·
Registered
Joined
·
187 Posts
[:)]We had the same problem with my buddies 400 xt and found out the chokes weren't working properly and was a common problem with a small part braking in the carbs. We got a choke rebuild kit and the sled just perfect now. Its just a thought but should be looked into. Good luck.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
thought of that too. the choke appears to be working ok. i would like to just buy a new carb. for it. any of you guys know where i could get one for it?
 

·
Registered
Joined
·
4,322 Posts
did you make sure your choke is closing all the way? make sure the cable is adjusted so there is around an 1/8th inch of free play in it and try it then. also your needle should be set in the middle position.
 

·
Registered
Joined
·
146 Posts
I believe stock jetting on that was 190 but would have to check to make sure. Don't buy a new carb, just adjust the jam nut on the choke so it sits in there nice. Did you check the float level in the carb? Replace needle and seat?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
i'm farely sure that the choke is closing all the way, it has about an 1/8" slack in it. i haven't replaced the needle or seat yet. i'm not for sure where the needle is set at, going to check it in a few. thanks for the advice guys
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
you guys know what size the carb is. i'm going to go ahead and order the needle and seat but all i have is the model number of the carb. it is am55053. anyone what size mm that is?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
thanks alot. i'm going to a couple local places today to see if i can get a rebuild kit for it. hopefully this will take care of my probelms. anyone know where i can get a new gas tank for it? parts are kinda hard to come by for this thing.
 

·
Registered
Joined
·
146 Posts
Make sure when you order that carb kit that you get a spigot mount kit and not a flange mount. The two have different parts.

As for other parts and info check out http://www.jdsleds.com goto the classifieds and you will surely find a gas tank.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
the other day when i had it running i sprayed some starter fluid around the seal and it reved up pretty good so i guess my crank seal is shot. i ordered a complete gasket set and new needle and seat. hopefully i'll be good to go then. anyone have any helpful hints on anything to watch out for while doing the crank seal? thanks for all the replies.
 

·
Registered
Joined
·
146 Posts
You hit it on the nose with the starting fluid.

The deal with that Kawi motor is the crank seals have a lip on them and you are supposed to split the case to install them properly. I don't know if you can cheat. However you can buy other seals that are the same size without the lip. Either way, be sure to grease up the seal good to avoid burning it away against the crank.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
i was planning on splitting the case anyways. i'll have to look at it alittle bit first and see if i can't get away with not having to though.
 
1 - 13 of 13 Posts
Top