Snowmobile Fanatics banner
1 - 18 of 18 Posts

·
Registered
Joined
·
580 Posts
always wanted to do that to my old 94 sks.....I was told i couldnt get my 79 500 3 cylinder into a 85 chassis.NO PROBLEM.

Its a wedge so it should fit. id pull pri and sec clutches and put the storm ones on.gearing???
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #5 ·
Yeah its the x-12 chassis I have it and it's in excellent shape, so that's why it's going under the knife. This is not a stock 800 so the clutching and carbs will be adjusted. I'll probably long track it again as well.
 

·
Registered
Joined
·
77 Posts
Hopefully Phil will chime in I know he's done this one . Just got done putting an 800 xcr motor in a 96 ultra and it was straight and simple. Like previous post said use the 800 primary and secondary also check your center to center so you know what belt to use . Got lucky on mine both strap mounts were the same I think you'll find the same. Air box could be tricky was on mine . Do you have a donor sled or just a motor ? Good luck
 

·
Registered
Joined
·
8,842 Posts
the biggest thing is to make sure the xlt mounts are in the same spot as the storm mounts. after that it is a bolt in and go.
 

·
Registered
Joined
·
2,257 Posts
Originally posted by madcow
[br]the biggest thing is to make sure the xlt mounts are in the same spot as the storm mounts. after that it is a bolt in and go.
That's my question as well. The xtra-12 uses different motor straps and is a pain to get pipes to fit. If their different, use the storm straps and drill new holes in the bulkhead. It should bolt in after that. Pipes are the next pain. My xlt with ultra big bore.
[attachment=49278]
[attachment=49279]
 

·
Registered
Joined
·
2,257 Posts
I modded the sled. Those are the biggest cans I ever put into a wedge. Not custom fit pipes but ultra big bore pipes for the 96 ultra. Into a xlt sp w/xtra-12. The position of the motor is not stock. Shimming and relocating the mount holes in the bulkhead did the trick. Perfect clutch alignment and I only had to shave the hood a little in a couple places to clear. Can't tell from the outside.[;)]
 

·
Registered
Joined
·
2,257 Posts
It was a 680 when setup originally. It's been modded since and will be swapped out as soon as the other motor is done. I'm stepping it up to ves. Getting back to the subject, the storm motor is still one helluva good running motor. You'll be happy.[:)]
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #17 ·
Yeah I think it will be ok, it not stock either , port head doesn't run well on pump gas.
Ultra 680 and suggestiong on what I should start with for pipes? Are the center distances the same for the 680 to the 800 do you know?
 

·
Registered
Joined
·
2,257 Posts
Originally posted by Memphis
[br]Yeah I think it will be ok, it not stock either , port head doesn't run well on pump gas.
Ultra 680 and suggestiong on what I should start with for pipes? Are the center distances the same for the 680 to the 800 do you know?
If your motor is hopped up, then custom fit pipes are the best choice. Center distance? Never been an issue so never checked.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top