Snowmobile Fanatics banner

1 - 16 of 16 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Here's what it is going. With engine cold I put choke on full pull it 2-3 times, it might fire but will not run, the plugs will be soaked. I dry the plugs out, pull it with no choke and a little bit of throttle and she will usually run for a couple of seconds if I give it gas, then it will die. I will have to do this a half a dozen times before she will run.I have gone through the carbs 4 times trying different float levels, the carbs are clean. The starter plungers seem to be fine. New plugs, new coil. And when I finally get the thing going it runs like a top, idles great very responsive, and the plugs will be a very light tan. Any advice would be greatly appreciated.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
fuel pump seems alright, good flow when disconnected. I'm wondering if it is a bad stator or bad compression.Any thoughts
 

·
Registered
Joined
·
155 Posts
im sorry.. its most likely not reeds.. um, Check and see what kind of spark you are getting, try cutting back spark plug wires and getting new caps and a hotter plug for it. If its still poor spark, then maybe you have an issue. but most likely nothing serious.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
I Had this thing flooded so many times they should be spotless but I will check them. if they are dirty i'm guessing soapy water to clean them or can I use carb cleaner
 

·
Registered
Joined
·
155 Posts
carb cleaner... and.. maybe you have a vacume line run wrong on carbs? Just rememer.. you need to be 1 percent smarter than your machine to figure this out.. you'll get it! lol
 

·
Registered
Joined
·
155 Posts
a hotter plug is BR8ES. Smaller the Number, hotter the Plug. Atleast for NGK. Also, Theres BR7, but i wouldnt recomend it. Try running 8's. and check all lines on carbs and reeds. you figure it out. Phazers are awesome sleds, and not too complicated
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
Is it possible to have a weak spark at start up and at idle and not while the engine is reved up if so would this be the magneto coils or possibly the cdi. My buddy noticed when it was idling the head light would serge brighter all of a sudden and then go real dim again with out a change in idle speed.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
well I tore into the engine, pulled the jugs off and what did I find? the piston pin clip (circlip) fell out and scored the cylinder about an 8th of an inch deep. crazy thing is it didn't take out the rings so the compression was still around 117 cold on both sides. anybody know how much it would cost to press in a new sleeve
 

·
Registered
Joined
·
155 Posts
make sure when you put in your cir clips, the opening is facing up or down, and not to the sides. And it isnt too much to get the cylinder fixed. Take it to your local Napa Machine shop and it wont bust your wallet too much.
 

·
Registered
Joined
·
1 Posts
And if you can possible afford it go with the Factory pistons if you can just a recomendation i got from one of the motor builder guy when i poped the piston in my indy
 
1 - 16 of 16 Posts
Top