Snowmobile Fanatics banner

1 - 14 of 14 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter #1
Having some problem I had last year,in which I took to a dealer and they had it running in an hour.Drove sled on trailer last season and no spark this fall.Tried unplugging safety switchand ignition with no result.Tried cleaning connectors nothing.The lights glimmer when I pull it but no spark.Any Ideas------Im frustrated[:(]
 

·
Registered
Joined
·
1,428 Posts
CDI box, check ebay, thats where you get them the cheapest
 

·
Registered
Joined
·
198 Posts
Discussion Starter #3
I dont think its the cdi didnt have to buy any parts last year.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #4
does the cdi need to be grounded or does it just sit on the block where it is??
 

·
Registered
Joined
·
1,428 Posts
the CDi does need to be grounded, and the CDI can burn up at the snap of you rfingers, no warning signs what so ever
 

·
Registered
Joined
·
198 Posts
Discussion Starter #6
would this sled have a bypass plug?Another forum was talking about cats having these,butnot sure where or what they are..
 

·
Registered
Joined
·
198 Posts
Discussion Starter #7
anyone know where to get wiring diagrams for free on the net?
 

·
Registered
Joined
·
1,428 Posts
alpha-sports.com
 

·
Registered
Joined
·
198 Posts
Discussion Starter #9
My cdi is plastic what would it be grounded to ?
 

·
Registered
Joined
·
1,428 Posts
There is probably just one wire that goes to some kind of metal
heres a CDI for ya http://cgi.ebay.com/ebaymotors/1985-ARCTIC-CAT-EL-TIGRE-SNOWMOBILE-CDI_W0QQcmdZViewItemQQcategoryZ100468QQihZ015QQitemZ250067042075QQrdZ1QQsspagenameZWD1V
 

·
Registered
Joined
·
198 Posts
Discussion Starter #11
well I used bypass plug and got the motor to run,s!#t luck im thinking, cause I let it run and put drygas in it and it ran for about 8 min. and died,I immediatly tried to start it and nothing put a plug in the wire and held it no spark again.checked bypass was ok.So now im not sure what to think?
 

·
Registered
Joined
·
198 Posts
Discussion Starter #12
Was told today that if you have no spark to take the cdi off hold a hair dryer on the bottom for a while and get it warm,then plug it back in and see if you get spark if you do the cdi is bad.Came from a arctic cat dealer.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #13
This actually worked and I double checked by testing it on another sled with the same box.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #14
I took a cdi off an older 83 cat that had the same kind of connections and it fired up but don't know if this will hurt anything else?
 
1 - 14 of 14 Posts
Top