Snowmobile Fanatics banner

1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hey guys i have a 93 Indy 500EFI that i want to swap a xtra 10 into it.. i bolted the rear up in the tunnel in the stock holes and now the susupension is hard as rock wont compress at all.. can someone give me some advise on Y it is doing this? thanks
 

·
Registered
Joined
·
2,109 Posts
You can't bolt it into the stock holes. The mounting points need to be moved to Extra-10 specs. This will help.

http://www.snowmobilefanatics.com/forum/topic/36287-looking-upgrade-an-xtra-10
 

·
Registered
Joined
·
652 Posts
tnmemr's got it right. Follow the thread and you will be a happy camper. A lot of us on the site have done the swap and couldn't be happier. Good luck and don't try any shortcuts.[thumb]
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Thanks guys but how come it bolts right up though and it doesnt work just curious.. thank you again.. i will post the results. Hopefully i can get in the shed tonight to work on it
 

·
Registered
Joined
·
2,109 Posts
You can move the rear torque arm to where it will bolt in, but the geometry is wrong. Follow the measurements at http://www.jbshocks.com/tech.html and you will be much happier. If you don't already have Fox shocks or an equivalent in the Extra-10, get a pair for the skid. You won't regret it. My personal faves are from a 98 XCR 440.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #6 ·
Hey guys thanks for the help.. Finally got around to it. Just hand to move the holes 1 1.25 forward.. now it works perfect. just have to dial it in.. THanks again. great site
 
1 - 6 of 6 Posts
Top