Snowmobile Fanatics banner
21 - 23 of 23 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #21 ·
stock plug does not match up to the ignition switch. The stock pl
Put everything back together and check to see if you have 12 volts coming out of this when you pull the cord with a multi-meter. You may have said but I did not see it. Just stated the fuel pump was not working.
View attachment 532735

If you have 12 volts coming out of the O/BLK

Check this plug next
View attachment 532733
View attachment 532734
I have confirmed that there is no 12V on the O/BLK, however, I've bypassed the ACS by sending 12V directly down O/BLK by jumping it with the red wire that was sending power to the ACS.
I hadn't verified that particular plug yet, but will do so today.
Thanks for the suggestion!
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #22 ·
I wanted to provide an update now that I've got the sled running.

Firstly, thanks so much to all of you guys for the help.
I verified with zero doubt that the ACS was dead, so I executed the ACS delete procedure as per the instructions on the following Facebook group: (https://www.facebook.com/groups/RXLgeek/)

I managed to find an ECU off of a 1992 Polaris, and attempted to swap the ROM chip, but ended up bending 2 pins (facepalm) - so I am running the donor ROM which seems to be working well thus far. (I am told the fuel mappings in the two ROMs are the same).

In the end, after bypassing the ACS, and swapping out the ECU (and ROM) - I was still getting a solid light on the ECU. (This is not a documented "code").

I traced through all of the pins on the ECU connector, and pin 106 (R/GN) had 0V when it should have had battery voltage. After tracing it down, and finding the broken connector, then reconnecting it - the sled fired right up.

So! if anyone out there gets a solid code out of the ECU, look at pin 106!

After bypassing the ACS, I wanted to install a new Kimpex 01-154-16 regulator, but shipping is taking forever, so I just used the regulator 'part' of the ACS, without the Alternator Controlled Switch part, and it seems to be working so far. After starting the sled a few times and running it for about 30 minutes - I checked the battery voltage and it is 13.3V.

Electrically, the only other thing I did was install a tether to the ignition, and an inline blade fuse holder (15A) in place of the circuit breaker.
I used some Gorilla 4" wide waterproof tape to fix some tears in the seat. (Man, that stuff is amazing).

The only way I was able to fix this sled was because of the kind and generous help of others.
Hopefully, these findings may help someone get some old sled running someday.
Thanks again!
 

Attachments

·
Registered
Joined
·
1 Posts
Good day!

A little background: I have a hobby of tinkering with motorcycles. I've restored and built a number of bikes. This is why my buddy contacted me last week.
His son traded his dirt bike for this sled (93 Polaris Indy 500 EFI). When they got it a few weeks ago, they had it running and could run it round the yard a bit on the grass. When he went out to start it recently after we got a bit of snow, it was completely dead. No response at all. My buddy knew I worked on bikes so he brought it over hoping I could help get it running. The young guy who traded his dirt bike for this thing is obviously pretty upset and I'd really like to help.

I've been doing some research on these machines, and this forum was where almost all of the good knowledgeable info has come from so far. So I thought I'd fire up a thread in hopes of enlisting some help. To be completely honest, although I've worked on other types of machines, I don't have experience working on snow machines.

Ok - the lowdown so far..

  • Good spark at both plugs.
  • I know that these EFI sleds require a juicy battery to start up. I have a trickle charger on the battery and it's > 13V.
  • No electric start on this sled, just pull start.
  • As I understand it, when I pull to start it, I should hear the fuel pump start up. I don't.
  • I checked the fuel pump (by jumping it to the battery) it runs without any problems when wired this way.
  • I replaced the inline fuel filter with a new one.
  • I got a wiring diagram from this site, but it looks like someone has modified the wiring. (stock wiring diagram attached)
  • My first thinking was to check fuses and relays. I can't find any fuses or fusible links anywhere.
  • When I check the resistance across the two (black - four contact) relays mounted on the ECU, I get 100 ohms as expected, however when putting 12v across the other two contacts, I see no change in the 100 ohm resistance. I was trying to test these relays as shown on the instructions attached to this post.(relays(1).pdf) - it seems unlikely both are bad, so I must be doing something incorrect in my test? I'd love to know how to properly verify these relays are functional.
  • Following that, it seems that the next step is to verify the ACS, as this component is responsible for firing up the fuel pump when the cord is pulled (which isn't happening).I found some guidance about testing the ACS but I don't understand it. I also can't find the actual ACS - I don't know where it's mounted.

I'm attaching a number of pictures of the wiring on this sled. Maybe it will help someone more knowledgeable than myself understand the intent of what has been modified, and what to do about it.

Please help if you can. I'd really like to get this sled running for my buddy's son. Any and all guidance is appreciated..
Fuel hoses going to the tank and the pick up tube in the tank.
 
21 - 23 of 23 Posts
Top