Snowmobile Fanatics banner

1 - 10 of 10 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
my rxl 650 efi seems to be slugish until i hit about 20-25 mph
it ran great then i didnt ride for a week or so and the last two times ive tried to ride its seemed kind of doggish
problems
ive been running regular gas in it
sometimes sputters after start up when i give it throttle
bogs down when climbing if i dont have a good run at it
air box filled up with snow a few times when rideing in deep powder
things ive done
toped it off with non-ehynol gas today about three gallons
put some new plugs in but think that made it worse went from autolite 4063 to ngk br9es the guys i was rideing with told me to take the 9es out and we put some old 8es in and it helped a little
ive used heat in it all year to try to keep the water out of the tank
its got a new battery
im sure the injecters are dirty with the ethynol gas is there a good injecter cleaner i can add to the gas
any advise is welcome thanks
 

·
Registered
Joined
·
9,987 Posts
Be careful using cleaner in ethanol fuel, I was getting detonation in my touring sled using it.

Try this. Drain the entire tank, refill with 93 octane non-ethanol, add heet, and carb cleaner and run the entire tank through. Then see how it is.
 

·
Registered
Joined
·
59 Posts
My 92 RXL is doing the same thing (perhaps even worse, cant even get it to 25). The last time it acted like this I replace the fuel filters and it cleared up and full power was back. I am going to try that solution again. Also I have had success running Lucas Lubricant/injector cleaner. I think the extra lube it priovides helps prevent detonation while alllowing the injectors to be cleaned. Hard part for me is inablilty to get non ethanol fuel. So I have to be careful will report back on filter change results.
 

·
Registered
Joined
·
5 Posts
I had a similar issue with my indy it would idle great as soon as I gave it gas it would bog right down. Mine turned out to be mice got into my exaust and plugged it up. I cleaned it out and it runs great now. Have a look anyway cant hurt.
 

·
Registered
Joined
·
8 Posts
my sled had been really boggy till you got above 30. found the wieghts in the primary clutch wore out and binding. put new weights in and its like a whole different sled. they were the wieghts for 92 and 5000 miles on them
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #8 ·
thanks for the help guys. i put a new belt on it today and took it around the yard a few times seems to be a lot better cant wait to try it out in some deeper snow been raining here for the last week but next weekend im going to the hills
 

·
Registered
Joined
·
33 Posts
I am not too sure what plugs other people recommend, however, I have found that my 93 RXL 650 hates NGK plugs. Makes no sense to me, but anyways, I run Champion plugs (not 100% on what ones, I will check it out in a few minutes) and they seem to do great. I have been on the same set of them for 2 years now.
 
1 - 10 of 10 Posts
Top