Snowmobile Fanatics banner

1 - 8 of 8 Posts

·
Registered
Joined
·
489 Posts
Discussion Starter · #1 ·
hello im back into the snowmobileing game again, i bought a 1998 Ski doo formula 3 600 triple for 900.00.. I picked it up and the thing started first pull all the time and ran really good.. i put Fresh injection oil in Klotz and new gas and plugs. My problem now is it still fires up first pull and idles fine , but when you go to give it some gas to move the tracks it falls on its face and back fires..got gas compression an spark.. Didnt do an actual reading on compression but enough to blow thumb off spark plug hole.. any ideas.
 

·
Registered
Joined
·
9,987 Posts
It's summer, the sled is jetted wayyyyy to rich for summer, and you loaded up a plug...

Clean up the plugs with some carb cleaner and try again.
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #3 ·
kinda messed up my description its was running rough on old plugs so i put the new plugs in an same result
 

·
Registered
Joined
·
2,304 Posts
jetting would be a big issue in the summer vs. winter
you may want to pull your clutches, clean them, besure the parts are good inside, everything moves and set your secondary preload and belt deflection. clutches can cause your issue
Besure that the track turns, no bumbed bearings in the drive line, jack shaft, chain case, and skid
this also can cause your issue
I would also trust a gauge over a thumb any day, get a proper compression test done, so you know for a fact if more work is needed, 900 for a sled is cheap

good luck
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #5 ·
im bout to change chain case oil its shit brown haha were would the drain plug be an any way to flush that out??
 

·
Registered
Joined
·
3,100 Posts
Dont think there is one on that sled, pull the chaincase cover and exhaust and let her run out. The way I see it yes temp may be messing with it but probly not that much, I would say you have other problems. Start with carbs, jets tend to clog over the summer and needle and seats can also be an issue.
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #7 ·
BskidooC said:
Dont think there is one on that sled, pull the chaincase cover and exhaust and let her run out. The way I see it yes temp may be messing with it but probly not that much, I would say you have other problems. Start with carbs, jets tend to clog over the summer and needle and seats can also be an issue.
Yeah i think the carbs prolly need attention. i was going to sand and repaint the pipes anyways so the carbs will be easier to get at..
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #8 ·
bigdogdaddy69 said:
BskidooC said:
Dont think there is one on that sled, pull the chaincase cover and exhaust and let her run out. The way I see it yes temp may be messing with it but probly not that much, I would say you have other problems. Start with carbs, jets tend to clog over the summer and needle and seats can also be an issue.
Yeah i think the carbs prolly need attention. i was going to sand and repaint the pipes anyways so the carbs will be easier to get at..
yesterdays high here was 63 i started sled it seemed a lil rich but ran good. Im cleaning carbs in a few mins..
 
1 - 8 of 8 Posts
Top