Snowmobile Fanatics banner

1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
[/font=Arial][/size=6][black][/black]Hello, Just bought a 98 RMK 600. It starts right up, runs great for about a minute, then backfires and stalls. It won't start again unless choked. Any thoughts?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
[/font=Arial][/size=6][black][/black]I should also mention - seems to consistently get good spark.
 

·
Registered
Joined
·
2,573 Posts
Seems too easy but... do you let the sled warm up?? If yes...than I have no idea...I'll check the books...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
[/font=Arial][/size=6][black][/black]I let it warm up a couple minutes - What are typical symptoms of too little warm up?
 

·
Registered
Joined
·
146 Posts
I think usually if you have everthing tuned correctly, on a cold start it should run at a slightly higher idle rpm. As it gets warm the idle rpm will decrease back to the normal range.

On cold mornings I like to give the sled a good 5 minutes to warm up.
 

·
Registered
Joined
·
2,573 Posts
yeah...five minutes is good. If that's what you do, then maybe low-speed jet problem, either partially plugged, or wrong size...but that's just a guess.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
[/font=Arial][/size=6][black][/black]What about fuel filter or fuel pump. Could they cause this? If so, how to test them? I cleaned the carbs last night - they looked clean. Hope to put it back together today and test.
 

·
Registered
Joined
·
2,273 Posts
Is there smoke when it backfires? And what colour is it?

I could be that the float in the carbs is stuck?? Is it possible to run it before it backfires?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
[/font=Arial][/size=6][black][/black]Haven't noticed any smoke when it backfires. Starting cold, I flip the choke on full, it starts on the first pull, after about 30 seconds I cut choke back to half, after about another 30 seconds to a minute, I turn choke off. It runs great - full power - for maybe a minute or two, then a couple loud backfires and stall. It can only be started then with choke on (halfway works) - won't even fire with no choke. If I get it started again, it's the same sequence over and over - runs for a short time, backfires and dies.

I have the carbs out now. Stock jetting is 160 (main jet), 45 (pilot). I have 180 (main jet), and 40 (pilot). I'm told these jets should be fine - that stock was a little lean. Carbs looked clean, but I soaked in carb cleaner anyway. Floats appeared to be functioning. The choke valves were a little gunky (looks like maybe some locktite?) A guy at a local shop thinks choke is sticking, then cutting off when it backfires? Doesn't make sense to me why it would need to be choked to restart though if choke was stuck. I plan on cleaning the choke valves, lubing cables, put it all together and fire it up again this evening. What's a good way to check fuel pump? I'll also replace the fuel filter.
 

·
Registered
Joined
·
2,273 Posts
Well the backfires would be because not all the fuel is being used, so it builds up in the exaust pipes then when it ignites in the pipes, in stalls the sled. So I would be checking out you plugs and the strenght of your spark...
 

·
Registered
Joined
·
55 Posts
Wow! I have the same problem! Mine backfires when I try and warm it up. Hmm! If you find anything out please email me, ok?
 

·
Registered
Joined
·
366 Posts
My XLT will backfire if i start it and try to drive it right away and i have to use the choke to get it to start again. I just warm it up for a few minutes and there is no problem
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
[/font=Arial][/size=6][black][/black]I found gunk in the fuel screw of one carb. The choke valves were also caked up a bit. After cleaning the carbs it seems to run fine. I warmed it up for a couple minutes then rode it around the block - ran good, no backfiring.
 

·
Registered
Joined
·
2,273 Posts
Thats great. Glad you got it figured out. Its a nice reliefe when your sled runs well.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #15
[/font=Arial][/size=6][black][/black]Yeah, it sure felt good to open her up with no more backfiring or stalling. Also learned some good info through the process. Thanks for your thoughts.
 
1 - 15 of 15 Posts
Top