Snowmobile Fanatics banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
i hvae a 98 summit bought it two weeeks ago and i knew it needed a new exhaust sysem and needed good carb cleaning done and done lol i have now put a tuned pipe on it and now idle is at 1000 which i beleive is way to low.so i played with the carbs and now m at the point now where i have decent acceleration from start to half but half to bar no WAY boggey i need help with the proper settings of the carbs.

my other issue is that when i start the sled the oil gauge goes right to the top everytime so im kinda scared to try anything what would be the problem there?
 

·
Registered
Joined
·
3 Posts
98summitman said:
i hvae a 98 summit bought it two weeeks ago and i knew it needed a new exhaust sysem and needed good carb cleaning done and done lol i have now put a tuned pipe on it and now idle is at 1000 which i beleive is way to low.so i played with the carbs and now m at the point now where i have decent acceleration from start to half but half to bar no WAY boggey i need help with the proper settings of the carbs.

my other issue is that when i start the sled the oil gauge goes right to the top everytime so im kinda scared to try anything what would be the problem there?
i hope you got the proper pipes, that is the "ho" engine and stock pipe and y pipe off a regular 670 will give you problems!!!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
tata670ho said:
98summitman said:
i hvae a 98 summit bought it two weeeks ago and i knew it needed a new exhaust sysem and needed good carb cleaning done and done lol i have now put a tuned pipe on it and now idle is at 1000 which i beleive is way to low.so i played with the carbs and now m at the point now where i have decent acceleration from start to half but half to bar no WAY boggey i need help with the proper settings of the carbs.

my other issue is that when i start the sled the oil gauge goes right to the top everytime so im kinda scared to try anything what would be the problem there?
i hope you got the proper pipes, that is the "ho" engine and stock pipe and y pipe off a regular 670 will give you problems!!!
nope i didnt get a stock pipe i replaced everything from engine to can off "ho" 670 sled just went from my stock to tuned pipe with mbrp can wow great sound if it would just go allready like i said its good from the start to half throttle then half to full out just boggs thats why i cleaned out the carbs and put them back on but didnt think of writting down any of the settings "duhhh me lol"to excited just wanna ride ive been hearing nothing but insane crazzy stuff about these sleds so i bought this one

well i hope that you can help with the settings if possible thanks guys
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
flatlander_summit said:
If you still have dpm on the sled you could have a bad or pinched dpm line.
i dont mean to sound stupid but where can i find the dpm and what does it do this is the newest sled ive owned

thanks for the reply appreciate it
 

·
Registered
Joined
·
2,546 Posts
98summitman said:
flatlander_summit said:
If you still have dpm on the sled you could have a bad or pinched dpm line.
i dont mean to sound stupid but where can i find the dpm and what does it do this is the newest sled ive owned

thanks for the reply appreciate it

The dpm should be a series of small hoses that attach to the carbs and airbox. It works to automatically change the a/f ratio in the sled so you do not have to change jetting as often. I think dpm was available only on the 98 670 X model. All other models including the regular 670 had the HAC system which is the same concept, but I have no clue about them.
 

·
Registered
Joined
·
2,304 Posts
as well as flat landers questions

did you change the jetting and clutching as per the pipe builders reccomendations, this can also cause your issue, I had a HAC do the same thing yours is doing, found a kinked line
 
1 - 7 of 7 Posts
Top