Snowmobile Fanatics banner

1 - 10 of 10 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
I was out riding around my house last night and my temp light came on, so I pulled up to the garage. There was coolant spraying out of the pressure cap, and the resovoir was about to explode. So i depressureized it. I felt my rear coolers and they were cold. Next thing i did was take my coolant bleeder screw out and started it to see if coolant would shoot out, and it didnt.

What I am wondering is that does the waterpump belt run the oil pump also? If so could i have scored up my pistons from riding it a couple hundred yards after the belt broke?

Thanks

Jake
 

·
Registered
Joined
·
15,722 Posts
Possibly and yes it does run the pump.


[attachment=18610]


Get your new belt here...

http://www.hardcoresledder.com/forums/index.php?showtopic=215044
 

Attachments

·
Registered
Joined
·
72 Posts
Discussion Starter #3
Thanks xcr440, have you tried these belts yourself? I have been told by some members here that they are good belts.

Jake
 

·
Registered
Joined
·
855 Posts
how many miles did you have when she went????
 

·
Registered
Joined
·
15,722 Posts
Originally posted by FastJake
[br]Thanks xcr440, have you tried these belts yourself? I have been told by some members here that they are good belts.

Jake
No I haven't. I pulled my motor to check mine on the pro x, It spece'd alright. If I would of known about it. I would of put it in.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #6
Originally posted by 98700xcBB
[br]how many miles did you have when she went????
It had 2,600 on it when i got it. The odometer quit working a couple miles after and ive put 300 on this season. So about 3,000.
I havent tore it apart yet, but I am pretty sure that its the belt, only thing it could really be. I am also thinking of getting a 770 top end along with a big bearing kit and pipes this spring.
 

·
Registered
Joined
·
855 Posts
man if you just clutch that thing its a whole new machine.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #8
Originally posted by 98700xcBB
[br]man if you just clutch that thing its a whole new machine.
Ya, I keep hearing that. Right now it has a heel clicker clutch kit in it (was there when i got it) and it engages at 4000 and pulls hard to the top. But this spring i would also like to get a killer clutch setup for the 824's from some one. Do you know what is best for the 824 cyls.

Thanks,

Jake
 

·
Registered
Joined
·
2,518 Posts
almond/blue, 10-64's, silver/blue, 50-36 or hsp 36x.
 
1 - 10 of 10 Posts
Top