Snowmobile Fanatics banner
1 - 5 of 5 Posts

·
Registered
Joined
·
586 Posts
Discussion Starter · #1 ·
i put a throttle cable extension on my 01 600 xcsp ... i get it to go on there but i can't get it adjust right ... at best when the throttle lever is in the iddle position it is pulling half throttle on the carbs ... anyone else had this happen or know how to fix it?
 

·
Registered
Joined
·
1,374 Posts
Had the same problem on xcr, seems the throttle cable has to loop alot, there must be a better safer way out there
 

·
Registered
Joined
·
1 Posts
you might need to adjust the position of the handlebars or raise them a bit more you have to many kinks in the line and your throttle
is not moving freely.[|)]
are you using the extended brake line cause if not that tells me right there that you must rise to get that throttle cable straightened out and it should move free that should drop those rev's abit

let me know what happens i have a few more
tips for you cause I own a 03 xc 600 edge and
i rebuild it from the snow up.
 

·
Registered
Joined
·
160 Posts
on my xlt i had to reajust my carbs there wasnt enough ajustment on my extension what6 kiodn of extention you running i put a power madd on one ya had to adjust my carbs so it would work dont forget about the oil injection pump too
 

·
Registered
Joined
·
586 Posts
Discussion Starter · #5 ·
i have a six inch riser with all that **** done, wires extended, brake extension, ... the last thing is the throttle extension ... yes i know u have to extend the brakes ... it shouldnt matter where i put my handlebars ... the extension will fit with plenty of room ... the extension itself is long enough but it will not let me adjust it enough ... not enough slack in it
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top