Snowmobile Fanatics banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,669 Posts
Discussion Starter #1
got a '76 merc trail twister, well, one problem was, the carbs were a little outta sync. but it still takes off liek a bat outta hell...the only problem is it dies out as it gets warmer[:(!]...what might my problem be...its gettin worse it'll run great for maybe 20 min and once the engine is warmed up, the sled will bog out.[xx(] I was flyin up some decent slopes, then it wanted to bog once i got on flat land, even just riding all flat land it does it...im pissed and tempted to sell it and buy a '96 Puma....
can anyone help[?]...robbie, i know u want the last option to happen[:p]
 

·
Registered
Joined
·
172 Posts
What kinda carbs were on that? I'd take the carbs off first and give them a good cleaning.

You can check to see if you have seals out of it by getting it good and hot, and then take some starting fluid and spray some down around the base of the engine. If your RPMs spike, you've got leaky seals.
 

·
Registered
Joined
·
1,669 Posts
Discussion Starter #4
its gettign even worse, once its warm, i cant go over 5 mph, it is definately the carb or fuel pump. how can i tell which isnt working right?
 

·
Registered
Joined
·
24 Posts
take them off, clean them, make sure the proper jets are in them, make sure that they are set in the air box right.
do you ride from your home or do you trailer to where you are going to ride?
 

·
Registered
Joined
·
1,669 Posts
Discussion Starter #6
i ride from my house and there is no air box or filters on them...i think ill have a break from ridin though, its been raining all day and it was 50 degreez....i live in western NY
 
1 - 7 of 7 Posts
Top