Snowmobile Fanatics banner

1 - 16 of 16 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter · #1 ·
I got my 91 indy 650 running again today, i just replaced my e-rings on my jet. Well i took it out for a ride and it was bogging a lot on low end and once i got it running high rpm`s it ran fine til i let off then got back on it, This is really bothering me and i would really appreciate some help. And i just got a new belt put on and, ever since the storm that froze everything its been running like this. [V] Replies are appreciated.
 

·
Registered
Joined
·
2,307 Posts
WOW, great find on that manual!!!

Have you bothered to change your needle n seats chipper?
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #7 ·
wow that manual has it all...but i havent changed my needle and seats so i guess i`ll start with that. Thanks.
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #8 ·
If i brung it down and had the shop place to put some new needle and seats. how much do they cost to buy, and how much do you think it would cost to have them installed? Thanks.
 

·
Registered
Joined
·
2,307 Posts
I don't think they're over $10 (US) a piece, $6 to $8 maybe. As for a shop putting them in, it shouldn't take any more than an hour at the MOST (1/2 hr) to install them all. So what ever the shop charges for an hourly rate ($30 to $40 per hr). They're real easy to change yourself though.
 

·
Registered
Joined
·
172 Posts
Yes, do all 3 of them.
I would urge you to do it yourself, Chipper... it's not hard & it's a good experience. You may have to take that apart out on the trail sometime, and it's hard enough when it's cold and dark when you know what you're doing, let alone figure out how to do it.
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #12 ·
i just replaced the needles and seats with a little guide i got from the shop...and it still is bogging well it helped a little bit but not a whole lot...but now if i handle the throttle right it wont bog but then in the midrange it still bogs and still is bogging a bit too...
 

·
Registered
Joined
·
128 Posts
need more info what and how many plugs fouling etc. can be a lot of things wrong those old girls had a few different problems list the things you have noticed to help narrow it down.[:eek:)]
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #15 ·
ok well i`ve noticed the plugs are all running the same and they foul a heck of a lot(every 30-40 miles), also i`ve noticed when i start it to idle and rev it up a little bit the tach jumps when i let off the throttle. Could this be a problem with the carbs thats what my friend thinks. And also he thinks it might be running rich. Could that be it? Thanks.
 

·
Registered
Joined
·
82 Posts
Chipper

This is what I understand about sparkplugs from reading this (great) forum. I am not sure about your tach, but as for the spark plugs ....

White
A white spark plug indicates that your fuel mixture is too lean (and a hole in the piston could be your next problem).

Brown
A brown spark plug indicates that your fuel mixture is a-ok.

Black
A black spark plug indicates that your fuel mixture is too rich.

Sorry I can't offer more, but I hope this helps!

TG
 
1 - 16 of 16 Posts
Top