Snowmobile Fanatics banner

1 - 6 of 6 Posts

·
Registered
Joined
·
288 Posts
Discussion Starter · #1 ·
okay so a few days after i got my car from my aunt the servie engine soon or check engine soon light came on..I cant remember which but whenever i turned my car on it shook pretty bad and then it went away and then it acted up again. I replaced the air filter a week ago and on friday when i started it up to leave school it started shaking again and I said some 4 letter words i cant repeat on here. and so anyways ive tried the whole diconnect your battery thing so its not that and it almost sounds like its firing wrong. my grandpa thinks its a coil going out. anyone have input?
 

·
Registered
Joined
·
380 Posts
Do a tune up (plugs, wires, rotor button, and distributor cap. Should do the trick. Is it shy on power as well? Hows it run in the rain or under wet conditions.
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #4 ·
yeah i was thinkin it was the plugs but my grandpa is trying to convince me its not cuz apparently they were just replaced but i think they need to be changed. and there isnt a real lack of power or anything. i think im going to take the plugs out and take a look at them
 

·
Registered
Joined
·
9,987 Posts
The next time that the light comes on, get a code reader and read the computer's error code... It will tell you what is wrong, instead of guessing.
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #6 ·
well im bringing it to my grandpas friends auto shop.. where the car was bought originally. so we will find out what is wrong
 
1 - 6 of 6 Posts
Top