Snowmobile Fanatics banner

1 - 11 of 11 Posts

·
Registered
Joined
·
644 Posts
Discussion Starter #1
hey every one i have a 02 mxz 800 and my clutch has a would pecker sound[:(] and i am affraid it would be bad before the season or if i am on a trip.......... any other 02 mxz in here have this specific problem it sounds like the primary has something possibly knocking inside,, piece of a weight broke loose?
 

·
Registered
Joined
·
1,898 Posts
which clutch? its probably your secondary. if you can take it and wiggle it front to back alot(from the front of the sled to therear) it will be that, that is making the sound. The key could be worn out or either of the two slots could be to do that. it may even be i nthe chain case, if the clutch will move but the shaft is moving with it, it could bet he chain being to loose and slammin to grab.
 

·
Registered
Joined
·
1,787 Posts
Originally posted by Boersy
[br]hey every one i have a 02 mxz 800 and my clutch has a would pecker sound[:(] and i am affraid it would be bad before the season or if i am on a trip.......... any other 02 mxz in here have this specific problem
Do you hear this sound when your sled is stopped and the engine is off?
 

·
Registered
Joined
·
963 Posts
look at the belt. you could have a chunk of it missing so everytime it goes around you hear a sound like that. does the noise speed up when the sled does?
 

·
Registered
Joined
·
644 Posts
Discussion Starter #5
hey guys no sorry i forgot to say that ... when its idling it does this and when i am driving it stays the same noise level so i even tell its there unless i am sitting idle
 

·
Registered
Joined
·
1,898 Posts
if it does it at idle it must be the primary. Check the weights, one clould have broke and flops around. Does it engage ruff and and how does it drive when your off and on the throttle.
 

·
Registered
Joined
·
644 Posts
Discussion Starter #7
it sorta engages rough i guess you could say well a little amount.. just like kicks on sometimes no so smooth
 

·
Registered
Joined
·
1,898 Posts
did you inspect your clutch yet?
 

·
Registered
Joined
·
707 Posts
If you haven't taken the clutches apart and you "think" that may be the problem, I would definitely inspect them. You don't want something bad to happen at 100mph.
 

·
Registered
Joined
·
2,124 Posts
check the primary bolt the clutch thats on the motor. check the bolt make sure its tight, my bro hade his come loose and wasnt pretty it made a weird sound all day and finally it came loose enough to let the spider out and boom.
 

·
Registered
Joined
·
644 Posts
Discussion Starter #11
thanks guys keep getting ppl to give me input .. i need it thanks
 
1 - 11 of 11 Posts
Top