Snowmobile Fanatics banner

1 - 8 of 8 Posts

·
Registered
Joined
·
443 Posts
Discussion Starter · #1 ·
Hey guys when i was out riding today i would stop and my sled would idle down to about 1200 rpm, then i would start out going slow and the clutch would start to squeak, i would then go faster and it would stop. I dont know if something has to be greased or what so i was hopeing you guys could help me out.
 

·
Registered
Joined
·
161 Posts
remove your belt and then see what she idles at.
 

·
Registered
Joined
·
443 Posts
Discussion Starter · #5 ·
71rdrnr said:
remove your belt and then see what she idles at.
I don't know my dad has the same sled and it idles at about 1200 rpm to.

It did this last year too, so i put a brand new belt on and it never did it till this year now.
 

·
Registered
Joined
·
4,016 Posts
As was said, you need to adjust your belt deflection most likely. Owner's manual will tell you how if you have one.
 

·
Registered
Joined
·
1,791 Posts
Look at your secondary clutch, on the face side should be a "gold" color plate with 3 bolts holding it on. On the plate should read 1-5, 1=tighter, 5=loosen...move the plate to the next highest number. That should get rid of the squeeking noise at idle.
 

·
Registered
Joined
·
2,125 Posts
I would rebuild the primary clutchand put new" washers" in under the spider. What has happened is the washers are crushed due to abuse. Really should replace every couple of years. If you wish to rebuild your primary. PM me and I can do the job for yah.
 
1 - 8 of 8 Posts
Top