Snowmobile Fanatics banner

1 - 4 of 4 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter #1
I have the classic dim lights until after warm up with my 95 Indy 500EFI. Last year it wasn't too bad. This year (back in mid December when we had a decent snow) it took darn near 8 miles before my lights would come on fully bright. Three days ago I cleaned all the connections (that used to help significantly in the past)but now I have decided to buy a new regulator. Finally my question. Of the three or four places I have checked on line none of them list a match to my sled (Polaris part # 4060122). DK has one that fits a bazzilion Polaris sleds but mine is not listed. Am I safe just buying the one listed for a 95 carb? Has anyone out there replaced a VR for an EFI sled with any success?
 

·
Registered
Joined
·
48 Posts
If it was any other sled i would say go for it, but where your is FI i might be inclined to look a little harder for the right voltage regulator only because FI runs on electricity and the correct regulator might be a litte more finicky on haveing the correct voltage
 

·
Registered
Joined
·
5,400 Posts
There are two regulators in the EFI sleds. The regulator for the EFI has 3 wires and the one for the lighting system has the two wires. So the carbed one should work. Many times they list just one of the regulators for the EFI sleds. I've also run into this issue.
 

·
Registered
Joined
·
340 Posts
Discussion Starter #4
Having said that- do you think I would be ok using the Polaris one that fits the carb-ed sleds?
 
1 - 4 of 4 Posts
Top